Added plugins settings
[oespirit1] / hildon-plugins-settings_0.0.10.bb
diff --git a/hildon-plugins-settings_0.0.10.bb b/hildon-plugins-settings_0.0.10.bb
new file mode 100644 (file)
index 0000000..5ab3a15
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Applets to control the hildon desktop plugins"
+HOMEPAGE = "http://maemo.org"
+LICENSE = "GNU Lesser General Public License-version 2.1"
+SECTION = "x11"
+DEPENDS = "libosso osso-af-settings hildon-control-panel hildon-desktop libhildon dbus-glib libhildonhelp"
+PR = "r1"
+
+SRC_URI = "http://repository.maemo.org/pool/diablo/free/h/${PN}/${PN}_${PV}-1.tar.gz  \
+           file://hildon-plugins-settings/mer-changes.patch;patch=1"
+
+inherit autotools pkgconfig
+
+# A test workaround to fix the "No GNU_HASH"
+# in elf binary issue            
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+FILES_${PN} += "/usr/lib/hildon-control-panel/*"
+
+
+do_stage(){
+    autotools_stage_all
+}
+
+