Initial commit
[bootcreen] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..3261823
--- /dev/null
@@ -0,0 +1,73 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+APPNAME := bootscreen
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       -qmake
+       -/opt/qt4-maemo5/bin/qmake-qt4
+       touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp  
+       dh_testdir
+       $(MAKE)
+       touch build-stamp 
+
+clean: 
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       -$(MAKE) clean
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+       $(MAKE) DESTDIR=$(CURDIR)/debian/$(APPNAME) install
+
+binary-indep: build install
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs
+       dh_installdocs
+       dh_installexamples
+       dh_install
+       dh_installmenu
+       dh_installdebconf       
+       dh_installlogrotate
+       dh_installemacsen
+       dh_installpam
+       dh_installmime
+#      dh_python
+       dh_installinit
+       dh_installcron
+       dh_installinfo
+       dh_installman
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+#      dh_perl
+       dh_makeshlibs
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure