update icons paths
[bootcreen] / debian / rules
old mode 100755 (executable)
new mode 100644 (file)
index 3261823..f3559e9
@@ -1,73 +1,72 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
-
-APPNAME := bootscreen
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       -qmake
-       -/opt/qt4-maemo5/bin/qmake-qt4
-       touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp  
-       dh_testdir
-       $(MAKE)
-       touch build-stamp 
-
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       -$(MAKE) clean
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-       $(MAKE) DESTDIR=$(CURDIR)/debian/$(APPNAME) install
-
-binary-indep: build install
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_install
-       dh_installmenu
-       dh_installdebconf       
-       dh_installlogrotate
-       dh_installemacsen
-       dh_installpam
-       dh_installmime
-#      dh_python
-       dh_installinit
-       dh_installcron
-       dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+#!/usr/bin/make -f\r
+# -*- makefile -*-\r
+# Sample debian/rules that uses debhelper.\r
+# This file was originally written by Joey Hess and Craig Small.\r
+# As a special exception, when this file is copied by dh-make into a\r
+# dh-make output file, you may use that output file without restriction.\r
+# This special exception was added by Craig Small in version 0.37 of dh-make.\r
+\r
+# Uncomment this to turn on verbose mode.\r
+#export DH_VERBOSE=1\r
+\r
+APPNAME := bootscreen\r
+builddir:\r
+       mkdir -p builddir\r
+\r
+builddir/Makefile: builddir\r
+       cd builddir && qmake PREFIX=/usr ../$(APPNAME).pro\r
+\r
+build: build-stamp\r
+\r
+build-stamp: builddir/Makefile\r
+       dh_testdir\r
+\r
+       # Add here commands to compile the package.\r
+       cd builddir && $(MAKE)\r
+       #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1\r
+\r
+       touch $@\r
+\r
+clean:\r
+       dh_testdir\r
+       dh_testroot\r
+       rm -f build-stamp\r
+\r
+       # Add here commands to clean up after the build process.\r
+       rm -rf builddir\r
+\r
+       dh_clean \r
+\r
+install: build\r
+       dh_testdir\r
+       dh_testroot\r
+       dh_clean -k \r
+       dh_installdirs\r
+\r
+       # Add here commands to install the package into debian/arora.\r
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install\r
+\r
+\r
+# Build architecture-independent files here.\r
+binary-indep: build install\r
+# We have nothing to do by default.\r
+\r
+# Build architecture-dependent files here.\r
+binary-arch: build install\r
+       dh_testdir\r
+       dh_testroot\r
+       dh_installdocs\r
+       dh_installexamples\r
+       dh_installman\r
+       dh_link\r
+       dh_strip\r
+       dh_compress\r
+       dh_fixperms\r
+       dh_installdeb\r
+       dh_shlibdeps\r
+       dh_gencontrol\r
+       dh_md5sums\r
+       dh_builddeb\r
+\r
+binary: binary-indep binary-arch\r
+.PHONY: build clean binary-indep binary-arch binary install configure\r