Packaging now works properly.
[confmgr] / debian / rules
index 3adfc4c..9516d4a 100755 (executable)
 #export DH_VERBOSE=1
 
 APPNAME := confmgr
-
 builddir:
        mkdir -p builddir
 
 builddir/Makefile: builddir
        cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       qmake confmgr.pro
-
-       touch configure-stamp
-
-
 build: build-stamp
 
-build-stamp: builddir/Makefile 
+build-stamp: builddir/Makefile
        dh_testdir
 
        # Add here commands to compile the package.
        cd builddir && $(MAKE)
-       #docbook-to-man debian/confmgr.sgml > confmgr.1
+       #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
 
        touch $@
 
@@ -52,6 +34,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        rm -rf builddir
+
        dh_clean 
 
 install: build
@@ -60,9 +43,10 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/confmgr.
+       # Add here commands to install the package into debian/arora.
        cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
 
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -71,27 +55,13 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
        dh_installdocs
        dh_installexamples
-       dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
-       dh_strip --dbg-package=confmgr-dbg
+       dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol