Add ARM files
[dh-make-perl] / dev / arm / libdevel-symdump-perl / libdevel-symdump-perl-2.08 / debian / rules
diff --git a/dev/arm/libdevel-symdump-perl/libdevel-symdump-perl-2.08/debian/rules b/dev/arm/libdevel-symdump-perl/libdevel-symdump-perl-2.08/debian/rules
new file mode 100755 (executable)
index 0000000..e9207a3
--- /dev/null
@@ -0,0 +1,69 @@
+#!/usr/bin/make -f
+# Made with the aid of dh_make, by Craig Small
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Some lines taken from debmake, by Cristoph Lameter.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+ifndef PERL
+PERL = /usr/bin/perl
+endif
+
+TMP     =$(CURDIR)/debian/libdevel-symdump-perl
+config  =INSTALLDIRS=vendor
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+CFLAGS := -O2 -g -Wall
+else
+CFLAGS := -g -Wall
+endif
+
+build: build-stamp
+build-stamp:
+       dh_testdir
+       $(PERL) Makefile.PL $(config)
+       $(MAKE) OPTIMIZE="$(CFLAGS)"
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       [ ! -f Makefile ] || $(MAKE) distclean
+       rm -f Makefile.old
+       dh_clean build-stamp install-stamp
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+
+       $(MAKE) install PREFIX=$(TMP)/usr
+       [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents $(TMP)/usr/lib/perl5
+
+       touch $@
+
+# Build architecture-independent files here.
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs ChangeLog
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_perl
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
+binary: binary-indep binary-arch
+.PHONY: build clean install binary-indep binary-arch binary