Add ARM files
[dh-make-perl] / dev / arm / libhtml-parser-perl / libhtml-parser-perl-3.56 / Makefile.PL
diff --git a/dev/arm/libhtml-parser-perl/libhtml-parser-perl-3.56/Makefile.PL b/dev/arm/libhtml-parser-perl/libhtml-parser-perl-3.56/Makefile.PL
new file mode 100644 (file)
index 0000000..79081f7
--- /dev/null
@@ -0,0 +1,30 @@
+require 5.006;
+use strict;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+    NAME        => 'HTML::Parser',
+    VERSION_FROM => 'Parser.pm',
+    H            => [ "hparser.h", "hctype.h", "tokenpos.h", "pfunc.h",
+                     "hparser.c", "util.c",
+                   ],
+    PREREQ_PM    => {
+                     'HTML::Tagset' => 3,
+                      'Test::More' => 0,    # only needed to run 'make test'
+                    },
+    DEFINE       => "-DMARKED_SECTION",
+    dist         => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+    clean        => { FILES => 'hctype.h pfunc.h' },
+);
+
+
+sub MY::postamble
+{
+    '
+pfunc.h : mkpfunc
+       $(PERL) mkpfunc >pfunc.h
+
+hctype.h : mkhctype
+       $(PERL) mkhctype >hctype.h
+'
+}