Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libhtml-parser-perl / libhtml-parser-perl-3.56 / debian / rules
diff --git a/dev/i386/libhtml-parser-perl/libhtml-parser-perl-3.56/debian/rules b/dev/i386/libhtml-parser-perl/libhtml-parser-perl-3.56/debian/rules
new file mode 100755 (executable)
index 0000000..1865ac0
--- /dev/null
@@ -0,0 +1,53 @@
+#!/usr/bin/make -f
+
+PERL=/usr/bin/perl
+
+binary: binary-arch
+
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs TODO
+       chmod a+x eg/hform
+       dh_installexamples eg/hanchors eg/hform eg/hrefsub eg/hstrip eg/htext eg/htextsub eg/htitle
+       dh_installchangelogs Changes
+       dh_strip
+       dh_fixperms
+       dh_compress
+       dh_installdeb
+       dh_perl
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary-indep: 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_installdirs
+       $(MAKE) install INSTALLDIRS=vendor PREFIX=$(CURDIR)/debian/libhtml-parser-perl/usr
+       rm -rf debian/libhtml-parser-perl/usr/share/perl5
+
+build: configure-stamp build-stamp
+build-stamp:
+       dh_testdir
+       $(MAKE) OPTIMIZE="-O2 -g -Wall"
+       $(MAKE) test
+       touch build-stamp
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       touch configure-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       if [ -e Makefile ]; then $(MAKE) -i distclean; fi
+       rm -f build-stamp configure-stamp
+       dh_clean 
+
+.PHONY: binary binary-arch binary-indep install build configure clean