Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libhtml-tree-perl / libhtml-tree-perl-3.23 / debian / rules
diff --git a/dev/i386/libhtml-tree-perl/libhtml-tree-perl-3.23/debian/rules b/dev/i386/libhtml-tree-perl/libhtml-tree-perl-3.23/debian/rules
new file mode 100755 (executable)
index 0000000..e65ad04
--- /dev/null
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+
+PERL=/usr/bin/perl
+
+binary: binary-indep
+
+binary-arch: 
+
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs README TODO
+       dh_installexamples htmltree
+       dh_installchangelogs Changes
+       dh_fixperms
+       dh_compress
+       dh_installdeb
+       dh_perl
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_installdirs
+       $(MAKE) install INSTALLDIRS=vendor PREFIX=$(CURDIR)/debian/libhtml-tree-perl/usr
+       rm -rf debian/libhtml-tree-perl/usr/lib
+
+build: configure-stamp build-stamp
+build-stamp: 
+       dh_testdir
+       $(MAKE)
+       $(MAKE) test
+       touch build-stamp
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       touch configure-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       if [ -e Makefile ]; then $(MAKE) -i distclean; fi
+       rm -f build-stamp configure-stamp
+       dh_clean
+
+.PHONY: binary binary-arch binary-indep install build configure clean