Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libpod-coverage-perl / libpod-coverage-perl-0.19 / debian / rules
diff --git a/dev/i386/libpod-coverage-perl/libpod-coverage-perl-0.19/debian/rules b/dev/i386/libpod-coverage-perl/libpod-coverage-perl-0.19/debian/rules
new file mode 100755 (executable)
index 0000000..bc0df6a
--- /dev/null
@@ -0,0 +1,58 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PACKAGE=$(shell dh_listpackages)
+
+ifndef PERL
+PERL = /usr/bin/perl
+endif
+
+build: build-stamp
+build-stamp:
+       dh_testdir
+       $(PERL) Build.PL installdirs=vendor
+       $(PERL) Build
+       $(PERL) Build test
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       dh_clean build-stamp install-stamp
+       [ ! -f Build ] || $(PERL) Build distclean
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       
+       $(PERL) Build install destdir=$(CURDIR)/debian/$(PACKAGE) create_packlist=0
+       rm $(CURDIR)/debian/$(PACKAGE)/usr/bin/pod_cover
+       rmdir --parents --ignore-fail-on-non-empty $(CURDIR)/debian/$(PACKAGE)/usr/bin
+       find $(CURDIR)/examples -type f -exec chmod +x {} \;
+       find $(CURDIR)/bin -type f -exec chmod +x {} \;
+       
+       touch $@
+
+binary-arch:;
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs Changes
+       dh_installexamples examples/* bin/*
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_perl
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure