Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libsub-uplevel-perl / libsub-uplevel-perl-0.1901 / debian / rules
diff --git a/dev/i386/libsub-uplevel-perl/libsub-uplevel-perl-0.1901/debian/rules b/dev/i386/libsub-uplevel-perl/libsub-uplevel-perl-0.1901/debian/rules
new file mode 100755 (executable)
index 0000000..75ea3c2
--- /dev/null
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+# export DH_VERBOSE=1
+
+include /usr/share/quilt/quilt.make
+
+PACKAGE=$(shell dh_listpackages)
+TMP=$(CURDIR)/debian/$(PACKAGE)
+
+ifndef PERL
+PERL = /usr/bin/perl
+endif
+
+build: build-stamp
+build-stamp: $(QUILT_STAMPFN)
+       dh_testdir
+       $(PERL) Build.PL installdirs=vendor verbose=1
+       $(PERL) Build
+       # xt/spelling.t lacks Test::Spelling so we only take the other xt/ tests
+       $(PERL) Build test --test_files 't/*.t' --test_files 'xt/[cp]*.t'
+       touch $@
+
+clean: unpatch
+       dh_testdir
+       dh_testroot
+       dh_clean build-stamp install-stamp
+       [ ! -f Build ] || $(PERL) Build distclean
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       $(PERL) Build install destdir=$(TMP) create_packlist=0
+       touch $@
+
+binary-arch:;
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples examples/*
+       dh_installchangelogs Changes
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_perl
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure