Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libtest-warn-perl / libtest-warn-perl-0.11 / Makefile.PL
diff --git a/dev/i386/libtest-warn-perl/libtest-warn-perl-0.11/Makefile.PL b/dev/i386/libtest-warn-perl/libtest-warn-perl-0.11/Makefile.PL
new file mode 100644 (file)
index 0000000..9e4a508
--- /dev/null
@@ -0,0 +1,23 @@
+use 5.006;
+use strict;
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+    'NAME'             => 'Test::Warn',
+    'VERSION_FROM'     => 'Warn.pm', # finds $VERSION
+    'PREREQ_PM'                => {    
+                            'Array::Compare'        => 0,
+                            'Test::Exception'       => 0,
+                            'Test::Builder'         => 0.13,
+                            'Test::Builder::Tester' => 1.02,
+                            'Sub::Uplevel'          => 0.12,
+                            'Tree::DAG_Node'        => 0,
+                            'File::Spec'            => 0,
+                            'Test::More'            => 0,
+                            }, # e.g., Module::Name => 1.1
+    ABSTRACT_FROM => 'Warn.pm', # retrieve abstract from module
+    AUTHOR        => 'Alexandr Ciornii <alexchorny'.'@gmail.com>',
+    ($ExtUtils::MakeMaker::VERSION ge '6.31'? 
+     ('LICENSE'                => 'perl', ) : ()),
+);