Move all code to a subdir for the garage repo
[g2-sharing] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index e71e7b7..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-       
-DEBDIR = ..
-       
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-       
-CFLAGS = -Wall -g
-       
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-       
-# Use soft-float and thumb mode if it enabled.
-ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -mthumb
-endif
-       
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-       INSTALL_PROGRAM += -s
-endif
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       DEB_CONFIGURE_EXTRA_FLAGS += --enable-debug
-endif
-       
-config.status: configure
-       dh_testdir
-    
-       CFLAGS="$(CFLAGS)" ./configure \
-               --host=$(DEB_HOST_GNU_TYPE) \
-               --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr \
-               --mandir=\$${prefix}/share-template/man \
-               --infodir=\$${prefix}/share-template/info \
-               $(DEB_CONFIGURE_EXTRA_FLAGS)
-
-configure: configure-stamp
-
-configure-stamp:
-       dh_testdir
-       ./autogen.sh
-       touch configure-stamp
-       
-build: build-stamp
-
-build-stamp:  config.status
-       dh_testdir
-
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       [ ! -f Makefile ] || $(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
-       cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
-       cp -f /usr/share/misc/config.guess config.guess
-endif
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_install --sourcedir=debian/tmp -v
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb --destdir=$(DEBDIR)
-       
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install