Move all code to a subdir for the garage repo
[g2-sharing] / sharing-plugin-gallery2 / src / Makefile.am
diff --git a/sharing-plugin-gallery2/src/Makefile.am b/sharing-plugin-gallery2/src/Makefile.am
new file mode 100644 (file)
index 0000000..d9d5558
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# This file is part of sharing-plugin-gallery2
+#
+# Copyright (C) 2009 Heikki Kallasjoki. All rights reserved.
+# Copyright (C) 2008-2009 Nokia Corporation. All rights reserved.
+#
+# This code is licensed under a MIT-style license, that can be
+# found in the file called "COPYING" in the root directory.
+#
+
+plugins_LTLIBRARIES = libsharingplugingallery2.la
+
+libsharingplugingallery2_la_SOURCES = plugin.c gallery2.c
+
+libsharingplugingallery2_la_CFLAGS = $(PACKAGE_CFLAGS) $(DEBUG_CFLAGS)
+libsharingplugingallery2_la_LDFLAGS = -module -avoid-version -export-dynamic
+libsharingplugingallery2_la_LIBADD = $(PACKAGE_LIBS)
+
+MAINTAINERCLEANFILES = Makefile.in