Import the initial Gallery 2 code
[g2-sharing] / src / Makefile.am
index f79d74c..d9d5558 100644 (file)
@@ -1,22 +1,19 @@
 #
-# This file is part of sharing-plugin-template
+# This file is part of sharing-plugin-gallery2
 #
+# Copyright (C) 2009 Heikki Kallasjoki. All rights reserved.
 # Copyright (C) 2008-2009 Nokia Corporation. All rights reserved.
 #
-# This maemo code example is licensed under a MIT-style license,
-# that can be found in the file called "COPYING" in the root
-# directory.
+# This code is licensed under a MIT-style license, that can be
+# found in the file called "COPYING" in the root directory.
 #
 
-plugins_LTLIBRARIES = libtemplate.la
+plugins_LTLIBRARIES = libsharingplugingallery2.la
 
-libtemplate_la_SOURCES = plugin.c common.c send.c validate.c
-
-libtemplate_la_CFLAGS = $(PACKAGE_CFLAGS) $(DEBUG_CFLAGS)
-libtemplate_la_LDFLAGS = -module -avoid-version -export-dynamic
-libtemplate_la_LIBADD = $(PACKAGE_LIBS)
+libsharingplugingallery2_la_SOURCES = plugin.c gallery2.c
 
+libsharingplugingallery2_la_CFLAGS = $(PACKAGE_CFLAGS) $(DEBUG_CFLAGS)
+libsharingplugingallery2_la_LDFLAGS = -module -avoid-version -export-dynamic
+libsharingplugingallery2_la_LIBADD = $(PACKAGE_LIBS)
 
 MAINTAINERCLEANFILES = Makefile.in
-
-