Uploaded initial version.
[guivpn] / trunk / vpngui / src / Makefile.am
diff --git a/trunk/vpngui/src/Makefile.am b/trunk/vpngui/src/Makefile.am
new file mode 100644 (file)
index 0000000..ea1ef32
--- /dev/null
@@ -0,0 +1,45 @@
+hildondesktoplib_LTLIBRARIES = libvpngui.la
+
+libvpngui_la_CPPFLAGS =                            \
+       -Werror                                      \
+       -Wall -g -O2                                 \
+       -DPACKAGE_LOCALE_DIR="\"/usr/share/locale\"" \
+       -DPIXMAPSDIR=\"$(pixmapsdir)\"               \
+       $(LIBHILDONDESKTOP_CFLAGS)                   \
+       $(STATUSBAR_SYNC_CFLAGS)                     \
+       $(CONIC_CFLAGS)
+
+libvpngui_la_LDFLAGS = -module -avoid-version
+
+libvpngui_la_LIBADD = \
+       $(LIBHILDONDESKTOP_LIBS)    \
+       $(STATUSBAR_SYNC_LIBS)      \
+       $(sbin_SCRIPTS)             \
+       $(CONIC_LIBS)
+
+#
+# The sync-plugin.la sources.
+#
+libvpngui_la_SOURCES =            \
+       macros.h                    \
+       vpngui.h                \
+       vpngui.c                \
+       vpnc-util.c                 \
+       vpn_notify.h                \
+       vpn_notify.c                \
+       vpncfg.h
+
+#
+# The desktop entry for the status menu plugin.
+#
+hildonstatusmenudesktopentry_DATA = vpngui.desktop
+
+sbin_SCRIPTS = vpngui-helper
+
+BUILT_SOURCES = vpn_notify-glue.h
+vpn_notify-glue.h: vpn_notify.xml
+               dbus-binding-tool --prefix=vpn_notify --mode=glib-server --output=$@ $<
+
+deb: dist
+               dpkg-buildpackage -rfakeroot
+