0.9.1.041-maemo.2 release tagged
[maemo-efl] / tags / 0.9.1.041-maemo.2 / eet / debian / rules
diff --git a/tags/0.9.1.041-maemo.2/eet/debian/rules b/tags/0.9.1.041-maemo.2/eet/debian/rules
new file mode 100755 (executable)
index 0000000..7692742
--- /dev/null
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+# Rewrote debian/rules to use cdbs.
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+
+DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
+        CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+endif
+