Including imlib2
[maemo-efl] / trunk / imlib2 / debian / rules
diff --git a/trunk/imlib2/debian/rules b/trunk/imlib2/debian/rules
new file mode 100755 (executable)
index 0000000..d61172c
--- /dev/null
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+
+DEB_DESTDIR = $(CURDIR)/debian/tmp
+
+DEB_CONFIGURE_EXTRA_FLAGS := --disable-mmx             \
+                                                        --disable-amd64        \
+                                                        --without-gif          \
+                                                        --without-id3
+
+DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+endif
+