Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / ext / theora / Makefile.am
diff --git a/gst-plugins-base-subtitles0.10/ext/theora/Makefile.am b/gst-plugins-base-subtitles0.10/ext/theora/Makefile.am
new file mode 100644 (file)
index 0000000..c4a5eec
--- /dev/null
@@ -0,0 +1,21 @@
+plugin_LTLIBRARIES = libgsttheora.la
+
+noinst_HEADERS = gsttheoraenc.h \
+                gsttheoradec.h \
+                gsttheoraparse.h
+
+libgsttheora_la_SOURCES = gsttheora.c \
+                         gsttheoraenc.c \
+                         gsttheoradec.c \
+                         gsttheoraparse.c
+
+libgsttheora_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(THEORA_CFLAGS)
+libgsttheora_la_LIBADD = \
+       $(top_builddir)/gst-libs/gst/tag/libgsttag-$(GST_MAJORMINOR).la \
+       $(top_builddir)/gst-libs/gst/video/libgstvideo-$(GST_MAJORMINOR).la \
+       $(GST_BASE_LIBS) \
+       $(GST_LIBS) \
+       $(THEORA_LIBS)
+libgsttheora_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgsttheora_la_LIBTOOLFLAGS = --tag=disable-static
+