Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / gst-libs / gst / Makefile.am
diff --git a/gst-plugins-base-subtitles0.10/gst-libs/gst/Makefile.am b/gst-plugins-base-subtitles0.10/gst-libs/gst/Makefile.am
new file mode 100644 (file)
index 0000000..c776f8e
--- /dev/null
@@ -0,0 +1,44 @@
+# The interfaces directory has to be built before the others,
+# otherwise some generated header files will be missing for the
+# plugins in the other directories.
+# Also, the tag directory has to be built before the cdda directory.
+SUBDIRS = \
+       interfaces \
+       tag \
+       audio \
+       cdda \
+       fft \
+       floatcast \
+       netbuffer \
+       riff \
+       rtp \
+       sdp \
+       rtsp \
+       video \
+       pbutils \
+       app
+
+noinst_HEADERS = gettext.h gst-i18n-plugin.h
+
+# dependencies:
+audio: interfaces
+
+cdda: tag
+
+riff: tag audio
+
+rtsp: sdp
+
+pbutils: video
+
+INDEPENDENT_SUBDIRS = \
+       interfaces tag fft floatcast netbuffer rtp sdp video app
+
+.PHONY: independent-subdirs $(INDEPENDENT_SUBDIRS)
+
+independent-subdirs: $(INDEPENDENT_SUBDIRS)
+
+$(INDEPENDENT_SUBDIRS):
+       $(MAKE) -C $@
+
+all-recursive: independent-subdirs