Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / gst-libs / gst / pbutils / Makefile.am
diff --git a/gst-plugins-base-subtitles0.10/gst-libs/gst/pbutils/Makefile.am b/gst-plugins-base-subtitles0.10/gst-libs/gst/pbutils/Makefile.am
new file mode 100644 (file)
index 0000000..fab6523
--- /dev/null
@@ -0,0 +1,136 @@
+lib_LTLIBRARIES = libgstpbutils-@GST_MAJORMINOR@.la
+
+headers_pbutils = \
+       pbutils.h         \
+       codec-utils.h     \
+       descriptions.h    \
+       encoding-profile.h      \
+       encoding-target.h       \
+       install-plugins.h \
+       missing-plugins.h \
+       gstdiscoverer.h
+
+# variables used for enum/marshal generation
+glib_enum_headers = $(headers_pbutils)
+glib_enum_define = PB_UTILS
+glib_gen_prefix = pbutils
+glib_gen_basename = pbutils
+
+built_headers_configure = \
+       gstpluginsbaseversion.h
+
+libgstpbutils_@GST_MAJORMINOR@_la_SOURCES = \
+       gstpluginsbaseversion.c \
+       pbutils.c         \
+       codec-utils.c     \
+       descriptions.c    \
+       encoding-profile.c      \
+       encoding-target.c       \
+       install-plugins.c \
+       missing-plugins.c \
+       gstdiscoverer.c   \
+       gstdiscoverer-types.c
+
+nodist_libgstpbutils_@GST_MAJORMINOR@_la_SOURCES = \
+       pbutils-enumtypes.c     \
+       pbutils-marshal.c
+
+libgstpbutils_@GST_MAJORMINOR@includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/pbutils
+libgstpbutils_@GST_MAJORMINOR@include_HEADERS = \
+       $(headers_pbutils)
+nodist_libgstpbutils_@GST_MAJORMINOR@include_HEADERS = \
+       $(built_headers_configure) \
+       pbutils-enumtypes.h
+noinst_HEADERS = \
+       pbutils-private.h
+EXTRA_DIST = pbutils-marshal.list
+
+libgstpbutils_@GST_MAJORMINOR@_la_LIBADD = \
+  $(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la \
+  $(GST_LIBS)
+libgstpbutils_@GST_MAJORMINOR@_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+libgstpbutils_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
+
+BUILT_SOURCES = \
+       pbutils-enumtypes.c \
+       pbutils-enumtypes.h \
+       pbutils-marshal.c   \
+       pbutils-marshal.h
+
+CLEANFILES = $(BUILT_SOURCES)
+
+# DISTCLEANFILES is for files generated by configure
+DISTCLEANFILES = $(built_headers_configure)
+
+include $(top_srcdir)/common/gst-glib-gen.mak
+
+if HAVE_INTROSPECTION
+BUILT_GIRSOURCES = GstPbutils-@GST_MAJORMINOR@.gir
+
+gir_headers=$(patsubst %,$(srcdir)/%, $(libgstpbutils_@GST_MAJORMINOR@include_HEADERS))
+gir_headers+=$(patsubst %,$(builddir)/%, $(nodist_libgstpbutils_@GST_MAJORMINOR@include_HEADERS))
+gir_sources=$(patsubst %,$(srcdir)/%, $(libgstpbutils_@GST_MAJORMINOR@_la_SOURCES))
+gir_sources+=$(patsubst %,$(builddir)/%, $(nodist_libgstpbutils_@GST_MAJORMINOR@_la_SOURCES))
+gir_cincludes=$(patsubst %,--c-include='gst/pbutils/%',$(libgstpbutils_@GST_MAJORMINOR@include_HEADERS))
+gir_cincludes+=$(patsubst %,--c-include='gst/pbutils/%',$(nodist_libgstpbutils_@GST_MAJORMINOR@include_HEADERS))
+
+GstPbutils-@GST_MAJORMINOR@.gir: $(INTROSPECTION_SCANNER) libgstpbutils-@GST_MAJORMINOR@.la
+       $(AM_V_GEN)PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" \
+               GST_PLUGIN_SYSTEM_PATH="" GST_PLUGIN_PATH="" GST_REGISTRY_UPDATE=no \
+               $(INTROSPECTION_SCANNER) -v --namespace GstPbutils \
+               --nsversion=@GST_MAJORMINOR@ \
+               --strip-prefix=Gst \
+               $(gir_cincludes) \
+               -I$(top_srcdir)/gst-libs \
+               -I$(top_builddir)/gst-libs \
+               --add-include-path=$(srcdir)/../video \
+               --add-include-path=`$(PKG_CONFIG) --variable=girdir gstreamer-@GST_MAJORMINOR@` \
+               --library=libgstpbutils-@GST_MAJORMINOR@.la \
+               --library-path=`$(PKG_CONFIG) --variable=libdir gstreamer-@GST_MAJORMINOR@` \
+               --library=gstreamer-@GST_MAJORMINOR@ \
+               --include=Gst-@GST_MAJORMINOR@ \
+               --libtool="$(top_builddir)/libtool" \
+               --pkg gstreamer-@GST_MAJORMINOR@ \
+               --pkg gstreamer-video-@GST_MAJORMINOR@ \
+               --pkg-export gstreamer-pbutils-@GST_MAJORMINOR@ \
+               --add-init-section="gst_init(NULL,NULL);" \
+               --output $@ \
+               $(gir_headers) \
+               $(gir_sources)
+
+# INTROSPECTION_GIRDIR/INTROSPECTION_TYPELIBDIR aren't the right place to
+# install anything - we need to install inside our prefix.
+girdir = $(datadir)/gir-1.0
+gir_DATA = $(BUILT_GIRSOURCES)
+
+typelibsdir = $(libdir)/girepository-1.0/
+
+typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
+
+%.typelib: %.gir $(INTROSPECTION_COMPILER)
+       $(AM_V_GEN)PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" \
+               $(INTROSPECTION_COMPILER) \
+               --includedir=$(srcdir) \
+               --includedir=$(srcdir)/../video \
+               --includedir=$(builddir) \
+               --includedir=`$(PKG_CONFIG) --variable=girdir gstreamer-@GST_MAJORMINOR@` \
+               $(INTROSPECTION_COMPILER_OPTS) $< -o $(@F)
+
+CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
+endif
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+       androgenizer -:PROJECT libgstpbutils -:SHARED libgstpbutils-@GST_MAJORMINOR@ \
+        -:TAGS eng debug \
+         -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+        -:SOURCES $(libgstpbutils_@GST_MAJORMINOR@_la_SOURCES) \
+                  $(nodist_libgstpbutils_@GST_MAJORMINOR@_la_SOURCES) \
+        -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstpbutils_@GST_MAJORMINOR@_la_CFLAGS) \
+        -:LDFLAGS $(libgstpbutils_@GST_MAJORMINOR@_la_LDFLAGS) \
+                  $(libgstpbutils_@GST_MAJORMINOR@_la_LIBADD) \
+                  -ldl \
+        -:HEADER_TARGET gstreamer-@GST_MAJORMINOR@/gst/pbutils \
+        -:HEADERS $(libgstpbutils_@GST_MAJORMINOR@include_HEADERS) \
+                  $(nodist_libgstpbutils_@GST_MAJORMINOR@include_HEADERS) \
+        -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+       > $@