Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / gst / typefind / Makefile.am
diff --git a/gst-plugins-base-subtitles0.10/gst/typefind/Makefile.am b/gst-plugins-base-subtitles0.10/gst/typefind/Makefile.am
new file mode 100644 (file)
index 0000000..3258b15
--- /dev/null
@@ -0,0 +1,26 @@
+plugin_LTLIBRARIES = libgsttypefindfunctions.la
+
+libgsttypefindfunctions_la_SOURCES = gsttypefindfunctions.c
+libgsttypefindfunctions_la_CFLAGS = \
+       $(GST_PLUGINS_BASE_CFLAGS) \
+       $(GST_CFLAGS) $(GIO_CFLAGS)
+libgsttypefindfunctions_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgsttypefindfunctions_la_LIBADD = \
+       $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
+       $(GST_LIBS) $(GIO_LIBS)
+
+libgsttypefindfunctions_la_LIBTOOLFLAGS = --tag=disable-static
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+       androgenizer \
+       -:PROJECT libgsttypefindfunctions -:SHARED libgsttypefindfunctions \
+        -:TAGS eng debug \
+         -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+        -:SOURCES $(libgsttypefindfunctions_la_SOURCES) \
+        -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgsttypefindfunctions_la_CFLAGS) \
+        -:LDFLAGS $(libgsttypefindfunctions_la_LDFLAGS) \
+                  $(libgsttypefindfunctions_la_LIBADD) \
+                  -ldl \
+        -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+                      LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+       > $@