* Fixes NB#87456, close "remove attachment" dialog with its parent
[modest] / configure.ac
1 # Copyright (c) 2006,2007 Nokia Corporation
2 # All rights reserved.
3
4 # Redistribution and use in source and binary forms, with or without
5 # modification, are permitted provided that the following conditions are
6 # met:
7
8 # * Redistributions of source code must retain the above copyright
9 #   notice, this list of conditions and the following disclaimer.
10 # * Redistributions in binary form must reproduce the above copyright
11 #   notice, this list of conditions and the following disclaimer in the
12 #   documentation and/or other materials provided with the distribution.
13 # * Neither the name of the Nokia Corporation nor the names of its
14 #   contributors may be used to endorse or promote products derived from
15 #   this software without specific prior written permission.
16
17 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
18 # IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
19 # TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
20 # PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
21 # OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
22 # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
23 # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
24 # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
25 # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
26 # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
27 # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
28
29 AC_INIT([modest],[1.0],[http://maemo.org])
30 AC_CONFIG_HEADERS([config.h])
31
32 AC_CONFIG_SRCDIR(src/modest-main.c)
33 AM_INIT_AUTOMAKE([dist-bzip2])
34
35 ALL_LINGUAS="en_GB"
36
37 MODEST_LOCALE_DIR='$prefix/${DATADIRNAME}/locale'
38 AM_GLIB_DEFINE_LOCALEDIR([MODEST_LOCALE_DIR])
39 AM_GLIB_GNU_GETTEXT
40
41
42
43 if test x$prefix = xNONE; then
44    prefix=/usr/local
45 fi
46 AC_SUBST(prefix)
47
48 AC_PROG_CC
49 AC_PROG_CXX
50 AM_PROG_CC_STDC
51 AC_HEADER_STDC
52 AC_PROG_LIBTOOL
53
54
55 # Option to enable debugging
56 AC_ARG_ENABLE(debug,
57               [AC_HELP_STRING([  --enable-debug],[Debugging (default=no)])],
58               [with_debug=yes], [with_debug=no])
59
60 if test "x$with_debug" == "xyes" ; then
61         CFLAGS="$CFLAGS -ggdb -O0 -DDEBUG -Wall"
62 else
63         CFLAGS="$CFLAGS -O2 -Wall"
64 fi
65
66
67
68 dnl -------
69 dnl GtkHTML
70 dnl -------
71
72 AC_MSG_CHECKING(for installed version of libgtkhtml3)
73 pkg-config --exists libgtkhtml-3.14
74 retval=$?
75 gtk_html_found=false
76 if test $retval -eq 0 ; then
77     gtk_html_found=true
78     gtk_html_version=3.14
79 else
80     pkg-config --exists libgtkhtml-3.8
81     retval=$?
82     if test $retval -eq 0 ; then
83       gtk_html_found=true
84       gtk_html_version=3.8
85     else
86           if [ $gui = "true" ]; then
87             AC_MSG_RESULT(libgtkhtml 3.4 or higher is not found!)
88           fi
89     fi
90 fi
91
92 if [ $gtk_html_found = "true" ]; then
93    version=`pkg-config --modversion libgtkhtml-${gtk_html_version}`
94    AC_MSG_RESULT(found version $version)
95 else
96    AC_MSG_ERROR([install gtkhtml 3.8 or newer])
97 fi
98
99
100 dnl # GLib/Gobject/Gtk/Gconf => mandatory
101
102 PKG_CHECK_MODULES(MODEST_GSTUFF,glib-2.0 >= 2.6 gobject-2.0 gtk+-2.0 >= 2.6 gconf-2.0 gnome-vfs-2.0 libgtkhtml-${gtk_html_version} libtinymail-1.0 libtinymail-camel-1.0 libtinymail-gnomevfs-1.0 libtinymailui-1.0 libtinymailui-gtk-1.0) 
103 AC_SUBST(MODEST_GSTUFF_CFLAGS)
104 AC_SUBST(MODEST_GSTUFF_LIBS)
105
106 modest_save_cflags="$CFLAGS"
107 modest_save_libs="$LIBS"
108 CFLAGS="$MODEST_GSTUFF_CFLAGS"
109 LIBS="$MODEST_GSTUFF_LIBS"
110 AC_CHECK_DECLS([gtk_widget_tap_and_hold_setup],[],[], [#include <gtk/gtk.h>])
111 CFLAGS="$modest_save_cflags"
112 LIBS="$modest_save_libs"
113
114 __COPY_LIBS="$LIBS"
115 LIBS="$LIBS $MODEST_GSTUFF_LIBS"
116 AC_CHECK_FUNCS(gtk_html_get_selection_area)
117 AC_SUBST(HAVE_GTK_HTML_GET_SELECTION_AREA)
118 AC_CHECK_FUNCS(gtk_tree_view_column_get_cell_data_hint)
119 AC_SUBST(HAVE_GTK_TREE_VIEW_COLUMN_GET_CELL_DATA_HINT)
120 LIBS="$__COPY_LIBS"
121
122 dnl dnl now, determine what to build
123 dnl AC_MSG_NOTICE([Determining what platform to build])
124 PKG_CHECK_MODULES(MODEST_MAEMO_LIBS,conic,[detected_platform=maemo],[detected_platform=gnome])
125
126 AC_ARG_WITH(platform, [
127 Target platform:
128   --with-platform=detect  detect target platform (default)
129   --with-platform=gnome   build for Gnome
130   --with-platform=maemo   build for Maemo
131 ],
132 [case "${with_platform}" in
133        gnome|maemo|detect)    MODEST_PLATFORM=${with_platform};;
134        *)        AC_MSG_ERROR([Unknown platform selected]);;
135 esac], [MODEST_PLATFORM=detect])
136
137 if test "$MODEST_PLATFORM" = "detect"; then
138         MODEST_PLATFORM="$detected_platform"
139         with_platform=$detected_platform
140 fi
141
142
143 dnl Whether to use maemo-launcher or not
144 AC_ARG_ENABLE([maemo-launcher],
145               [AS_HELP_STRING([--enable-maemo-launcher],
146                               [build with maemo-launcher support])],
147                               [case "${enableval}" in
148                                yes) maemo_launcher=true ;;
149                                no)  maemo_launcher=false ;;
150                                *) AC_MSG_ERROR([bad value ${enableval} for --enable-maemo-launcher]) ;;
151                                esac], [maemo_launcher=false])
152 if test x$maemo_launcher = xtrue
153 then
154         PKG_CHECK_MODULES(MAEMO_LAUNCHER, [maemo-launcher-app])
155         AC_SUBST(MAEMO_LAUNCHER_CFLAGS)
156         AC_SUBST(MAEMO_LAUNCHER_LIBS)
157 fi
158
159 have_easysetup=false
160 if test "x$with_platform" == "xgnome"; then
161       PKG_CHECK_MODULES(MODEST_PLATFORM,libtinymail-gnome-desktop-1.0 libnm_glib glib-2.0 >= 2.8 gtk+-2.0 >= 2.10 libnotify)
162     AC_DEFINE_UNQUOTED(MODEST_PLATFORM_GNOME, 1, ["Whether modest is being built for the GNOME platform."])
163 dnl     AC_MSG_ERROR([The GNOME Build is currently broken; please try the Maemo build instead])
164 else
165     have_easysetup=true
166     have_dbusapi=true
167     PKG_CHECK_MODULES(MODEST_PLATFORM,libosso dbus-1 libtinymail-maemo-1.0 libebook-1.2 )
168     AC_DEFINE_UNQUOTED(MODEST_PLATFORM_MAEMO, 1, ["Whether modest is being built for the MAEMO platform."])
169     AC_DEFINE_UNQUOTED(MODEST_HAVE_EASYSETUP, 1, ["Whether we have the easysetup feature"])
170 fi                  
171
172 AM_CONDITIONAL(MODEST_HAVE_EASYSETUP,test "x$have_easysetup" == "xtrue")
173 AM_CONDITIONAL(MODEST_HAVE_DBUS_API,test "x$have_dbusapi" == "xtrue")
174 AC_SUBST(MODEST_PLATFORM)
175
176
177
178 #
179 # check for wpeditor or libwpeditor-plus (on maemo)
180 #
181 if test "x$with_platform" == "xmaemo"; then  
182 PKG_CHECK_MODULES(MODEST_WPEDITOR,wpeditor,have_wpeditor=true,have_wpeditor=false)
183 if test "x$have_wpeditor" == "xfalse"; then
184    PKG_CHECK_MODULES(MODEST_WPEDITOR,libwpeditor-plus,have_libwpeditorplus=true,have_libwpeditorplus=false)     
185    if test "x$have_libwpeditorplus" == "xtrue"; then
186         wpeditor="libwpeditor-plus"
187         AC_DEFINE_UNQUOTED(MODEST_HAVE_LIBWPEDITOR_PLUS, 1, ["Whether libwpeditor-plus is used."])              
188    else
189         AC_MSG_ERROR([you need to have either wpeditor or libwpeditor-plus installed])
190    fi
191 else
192    wpeditor="wpeditor"  
193    AC_DEFINE_UNQUOTED(MODEST_HAVE_WPEDITOR, 1, ["Whether wpeditor is used."])           
194 fi
195 fi
196
197
198 #
199 # check libalarm
200 #
201 if test "x$with_platform" == "xmaemo"; then  
202 PKG_CHECK_MODULES(MODEST_LIBALARM,libalarm,have_libalarm=true,have_libalarm=false)
203 if test "x$have_libalarm" == "xtrue"; then
204    libalarm="libalarm"  
205    AC_DEFINE_UNQUOTED(MODEST_HAVE_LIBALARM, 1, ["Whether libalarm is used."])           
206    AC_SUBST(MODEST_LIBALARM_CFLAGS)
207    AC_SUBST(MODEST_LIBALARM_LIBS)
208 else
209    libalarm=""
210 fi
211 fi
212
213 #
214 # check for MCE
215 #
216 if test "x$with_platform" == "xmaemo"; then  
217 PKG_CHECK_MODULES(MODEST_MCE,mce,have_mce=true,have_mce=false)
218 if test "x$have_mce" == "xtrue"; then
219    mce="mce"    
220    AC_DEFINE_UNQUOTED(MODEST_HAVE_MCE, 1, ["Whether mce is used."])
221    AC_SUBST(MODEST_MCE_CFLAGS)
222    AC_SUBST(MODEST_MCE_LIBS)
223 else
224    mce=""
225 fi
226 fi
227
228 #
229 # check for libconic; this is a trick to check whether we run
230 # on a 'real' maemo platform, or on, say, ubuntu embedded
231 # this determines whether we build with the non-hildon GTK+
232 #
233 if test "x$with_platform" == "xmaemo"; then  
234 PKG_CHECK_MODULES(MODEST_LIBCONIC,conic,have_libconic=true,have_libconic=false)
235 if test "x$have_libconic" == "xtrue"; then
236    AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_GTK,1,["Whether modest is being built with Hildon/Gtk"])
237    AC_DEFINE_UNQUOTED(MODEST_HAVE_CONIC,1,["Whether modest has conic available"])
238    AC_SUBST(MODEST_LIBCONIC_CLAGS)
239    AC_SUBST(MODEST_LIBCONIC_LIBS)
240 else
241 # if we define this, tinymail will not try to #include conic headers
242    CFLAGS="$CFLAGS -DLIBTINYMAIL_MAEMO_WITHOUT_CONIC"
243 fi
244 fi
245
246 #
247 # check hildon-help (only for maemo)
248 #
249 if test "x$with_platform" == "xmaemo"; then  
250    PKG_CHECK_MODULES(MODEST_HILDON_HELP,hildon-help,have_hildon_help=true,have_hildon_help=false)
251    if test "x$have_hildon_help" == "xfalse"; then
252       PKG_CHECK_MODULES(MODEST_HILDON_HELP,libossohelp,have_osso_help=true,have_osso_help=false)        
253       if test "x$have_osso_help" == "xtrue"; then
254         helplib="osso-help"
255         AC_DEFINE_UNQUOTED(MODEST_HAVE_OSSO_HELP, 1, ["Whether osso-help is used."])            
256       else
257         AC_MSG_ERROR([you need to have either osso-help or hildon-help installed])
258       fi
259    else
260      helplib="hildon-help"      
261      AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_HELP, 1, ["Whether hildon-help is used."])           
262    fi
263 fi
264
265
266
267 #
268 # check for the notification stuff (only maemo)
269 #
270 if test "x$with_platform" == "xmaemo"; then  
271    PKG_CHECK_MODULES(MODEST_HILDON_NOTIFY,hildon-notify libnotify,have_hildon_notify=true,have_hildon_notify=false)
272    if test "x$have_hildon_notify" == "xtrue"; then
273       AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_NOTIFY, 1, ["Whether hildon-notify is available"])      
274    fi
275 fi
276
277
278 #
279 # check for the uri/mime stuff
280 #
281 if test "x$with_platform" == "xmaemo"; then  
282    PKG_CHECK_MODULES(MODEST_HILDON_MIME,libhildonmime,have_hildonmime=true,have_hildonmime=false)
283    if test "x$have_hildonmime" == "xfalse"; then
284       PKG_CHECK_MODULES(MODEST_HILDON_MIME,libossomime,have_ossomime=true,have_ossomime=false)  
285       if test "x$have_ossomime" == "xtrue"; then
286         mimelib="osso-mime"
287         AC_DEFINE_UNQUOTED(MODEST_HAVE_OSSO_MIME, 1, ["Whether osso-mime is used."])            
288       else
289         AC_MSG_ERROR([you need to have either osso-mime or hildon-mime installed])
290       fi
291    else
292      mimelib="hildon-mime"      
293      AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_MIME, 1, ["Whether hildon-mime is used."])           
294    fi
295 fi
296
297 PKG_CHECK_MODULES(MODEST_MOZEMBED, libtinymailui-mozembed-1.0, have_mozembed=true, have_mozembed=false)
298 AC_ARG_ENABLE(mozembed,
299 AC_HELP_STRING([--enable-mozembed],
300         [Build with GtkMozEmbed (yes, no)]),
301 [case "${enableval}" in
302       yes)
303         if test x$have_mozembed = xfalse; then
304            AC_MSG_ERROR([building of GtkMozEmbed support requested and gtkmozembed not found])
305         fi
306         use_mozembed=true
307         ;;
308       *)
309         use_mozembed=false
310         ;;
311 esac],[use_mozembed=false])
312
313 AM_CONDITIONAL(BUILD_MOZEMBED, test x$use_mozembed = xtrue)
314
315 if test x$use_mozembed = xtrue; then
316         AC_DEFINE_UNQUOTED(MODEST_USE_MOZEMBED, 1, ["Whether we use GtkMozEmbed."])
317 fi
318
319 #dnl wether we can and should build the 
320 #dnl search plugin (on maemo)
321 if test "x$with_platform" == "xmaemo"; then  
322 PKG_CHECK_MODULES(MODEST_OGS, libosso >= 0.8.5 libogs-1.2, have_ogs=true, have_ogs=false)
323 have_ogs_support=false
324 AC_ARG_ENABLE(ogs_support,
325 AC_HELP_STRING([--enable-ogs-support],
326         [Build with osso global search support (yes, no)]),
327 [case "${enableval}" in
328       yes)
329         if test x$have_ogs = xfalse; then
330            AC_MSG_ERROR([building of ogs support requested and libogs-1.2 not found])
331         fi
332         ;;
333       *) 
334         have_ogs_support=false
335         ;;
336 esac],[have_ogs_support=$have_ogs])
337
338 if test x$have_ogs_support = xtrue; then
339         AC_DEFINE_UNQUOTED(MODEST_HAVE_OGS, 1, ["Whether ogs is available."])
340 fi
341 fi
342
343
344
345 #
346 # check the version of the widgets on maemo
347 #
348 if test "x$with_platform" == "xmaemo"; then  
349 PKG_CHECK_MODULES(MODEST_HILDON_WIDGETS, hildon-1 >= 0.9.9 hildon-fm-2, have_hildon1=true,have_hildon1=false)   
350 if test "x$have_hildon1" == "xfalse"; then 
351    PKG_CHECK_MODULES(MODEST_HILDON_WIDGETS, hildon-libs >= 0.12.0 hildon-fm, have_hildon0=true,have_hildon0=false)      
352    if test "x$have_hildon0" == "xtrue"; then
353       AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON0_WIDGETS, 1, ["Whether hildon0 widgets are used."])               
354    else
355       AC_MSG_ERROR([hildon widgets and/or hildon-fm not found])
356    fi
357 else
358       AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON1_WIDGETS, 1, ["Whether hildon1 widgets are used."])             
359 fi
360 fi
361
362
363
364 #
365 # check the version of the addressbook on maemo
366 #
367 if test "x$with_platform" == "xmaemo"; then  
368    PKG_CHECK_MODULES(MODEST_ABOOK,osso-addressbook-1.0,have_abook=true,have_abook=false)
369    AC_SUBST(MODEST_ABOOK_CFLAGS)
370    AC_SUBST(MODEST_ABOOK_LIBS)
371
372    if test "x$have_abook" == "xtrue"; then
373       abook_api=`$PKG_CONFIG --modversion osso-addressbook-1.0 | cut -d. -f1`
374       AC_DEFINE_UNQUOTED(OSSO_ABOOK_ENABLE_DEPRECATED, 1, ["use deprecated addressbook API"])
375       AC_DEFINE_UNQUOTED(MODEST_ABOOK_API, $abook_api, ["the API version of osso-addressbook"])
376       AC_DEFINE_UNQUOTED(MODEST_HAVE_ABOOK, 1, ["whether we have osso-addressbook"])
377       addressbook="osso-addressbook"
378    fi
379 fi
380
381
382 #
383 # if we don't have an addressbook, use the dummy one
384 #
385 AM_CONDITIONAL(MODEST_USE_DUMMY_ADDRESS_BOOK,test "x$have_abook" != "xtrue")
386
387
388 # gettext support
389 GETTEXT_PACKAGE=modest  
390 AC_SUBST(GETTEXT_PACKAGE)
391 AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", ["gettext package"])
392
393
394 #
395 # settings for maemo platform
396 #
397 if test "x$with_platform" == "xmaemo"; then  
398
399   # warnings are errors, but don't check format errors, because
400   # it breaks with logical ids
401   CFLAGS="$CFLAGS -Wno-format-extra-args -Werror"
402
403    desktopentrydir=`$PKG_CONFIG osso-af-settings --variable=desktopentrydir`
404    serviceentrydir=`$PKG_CONFIG dbus-glib-1 --variable=prefix`/share/dbus-1/services
405    localedir=`$PKG_CONFIG osso-af-settings --variable=localedir`
406    backupsettingsdir=/etc/osso-backup/applications
407    pixmapdir=`$PKG_CONFIG osso-af-settings --variable=hildonpixmapdir`
408    icon_26x26dir=$datadir/icons/hicolor/26x26/hildon
409    icon_34x34dir=$datadir/icons/hicolor/34x34/hildon
410    icon_40x40dir=$datadir/icons/hicolor/40x40/hildon
411    icon_50x50dir=$datadir/icons/hicolor/50x50/hildon
412    icon_scalabledir=$datadir/icons/hicolor/scalable/hildon
413    pluginlibdir=`$PKG_CONFIG hildon-control-panel --variable=plugindir`
414    plugindesktopentrydir=`$PKG_CONFIG hildon-control-panel --variable=plugindesktopentrydir`
415
416    dbus_api="dbus_api"
417    AC_SUBST(dbus_api)
418
419    # Define as variables in Makefiles
420    AC_SUBST(desktopentrydir)
421    AC_SUBST(serviceentrydir)
422    AC_SUBST(backupsettingsdir)
423    AC_SUBST(localedir)
424    AC_SUBST(pixmapdir)
425    AC_SUBST(icon_26x26dir)
426    AC_SUBST(icon_34x34dir)
427    AC_SUBST(icon_40x40dir)
428    AC_SUBST(icon_50x50dir)
429    AC_SUBST(icon_scalabledir)
430    AC_SUBST(pluginlibdir)
431    AC_SUBST(plugindesktopentrydir)
432
433 else
434    # gnome frontend 
435    PKG_CHECK_MODULES(MODEST_LIBTINYMAIL_GNOME_DESKTOP,libtinymail-gnome-desktop-1.0 libnm_glib glib-2.0 >= 2.8 gtk+-2.0 >= 2.10 libnotify)
436    AC_SUBST(MODEST_LIBTINYMAIL_GNOME_DESKTOP_CFLAGS)
437    AC_SUBST(MODEST_LIBTINYMAIL_GNOME_DESKTOP_LIBS)  
438    AC_DEFINE_UNQUOTED(MODEST_PLATFORM_GNOME, 1, ["Whether modest is being built for the GNOME platform."])
439
440   # no dbus api for gnome
441   dbus_api=""
442   AC_SUBST(dbus_api)
443
444 fi
445
446
447 dnl ## setup the testing framework (ie., make check)
448 build_tests=false
449 AC_ARG_ENABLE(tests,
450 AC_HELP_STRING([--enable-tests],
451         [Build tests (no, yes)]),
452 [case "${enableval}" in
453       yes)
454         build_tests=true ;;
455       *) build_tests=false ;;
456 esac],[build_tests=false])
457 AM_CONDITIONAL(BUILD_TESTS, test x$build_tests = xtrue)
458
459
460
461 dnl ## is the check package installed?
462 if test x$build_tests = xtrue; then
463    PKG_CHECK_MODULES(CHECK, check >= 0.9.4 glib-2.0)
464 fi
465
466
467
468 dnl ## do we want documentation (gtk-doc)
469 build_docs=false
470 AC_ARG_ENABLE(docs,
471 AC_HELP_STRING([--enable-docs],
472         [Build documentation (yes, no)]),
473 [case "${enableval}" in
474       yes)
475         build_docs=true ;;
476       *) build_docs=false ;;
477 esac],[build_docs=false])
478 AM_CONDITIONAL(BUILD_DOCS, test x$build_docs = xtrue)
479
480 dnl ## gtk-doc
481 GTK_DOC_CHECK([1.0])
482
483 dnl Intltool utility programs
484 #AC_PROG_INTLTOOL([0.33.0],[no-xml])
485
486 AC_OUTPUT([
487 po/Makefile.in
488 Makefile
489 man/Makefile
490 src/Makefile
491 src/dbus_api/Makefile
492 src/gnome/Makefile
493 src/maemo/Makefile
494 src/maemo/easysetup/Makefile
495 src/widgets/Makefile
496 docs/Makefile
497 docs/reference/Makefile
498 tests/Makefile
499 tests/dbus_api/Makefile
500 src/maemo/modest.desktop
501 src/maemo/com.nokia.modest.service
502 libmodest-dbus-client/Makefile
503 libmodest-dbus-client/libmodest-dbus-client-1.0.pc
504 ])
505
506
507 echo
508 echo "modest configure results"
509 echo "-----------------------------------"
510 echo "Platform         : $with_platform"
511 echo "Prefix           : ${prefix}"
512 echo "Build tests      : $build_tests"
513 echo "Build docs       : $build_docs"
514 echo "Gettext Package  : $GETTEXT_PACKAGE"
515
516 if test "x$with_platform" == "xmaemo"; then
517    echo "Maemo Launcher   : $maemo_launcher"
518    echo "Editor lib       : $wpeditor"
519    echo "Addressbook      : $have_abook"
520    echo "Help lib         : $helplib"
521    echo "libconic support : $have_libconic"
522    echo "Alarm            : $have_libalarm"
523    echo "MCE              : $have_mce"
524    echo "Hildon-Notify    : $have_hildon_notify"    
525    echo "LibOGS support   : $have_ogs_support"
526    echo "MozEmbed support : $use_mozembed"
527 fi 
528
529 echo "CFLAGS           : $CFLAGS"
530 echo "Debug version    : $with_debug"
531 echo ""
532 echo "NOTE: you should do a 'make clean' after changing architecture or platform (--with-platform=)"
533 echo ""