Fixes NB#96600, added feed protocol support
[modest] / configure.ac
1 # Copyright (c) 2006,2007 Nokia Corporation
2 # All rights reserved.
3
4 # Redistribution and use in source and binary forms, with or without
5 # modification, are permitted provided that the following conditions are
6 # met:
7
8 # * Redistributions of source code must retain the above copyright
9 #   notice, this list of conditions and the following disclaimer.
10 # * Redistributions in binary form must reproduce the above copyright
11 #   notice, this list of conditions and the following disclaimer in the
12 #   documentation and/or other materials provided with the distribution.
13 # * Neither the name of the Nokia Corporation nor the names of its
14 #   contributors may be used to endorse or promote products derived from
15 #   this software without specific prior written permission.
16
17 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
18 # IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
19 # TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
20 # PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
21 # OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
22 # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
23 # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
24 # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
25 # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
26 # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
27 # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
28
29 AC_INIT([modest],[1.0],[http://maemo.org])
30 AC_CONFIG_HEADERS([config.h])
31
32 m4_define([modest_api_major_version], [1])
33 m4_define([modest_api_minor_version], [0])
34 m4_define([modest_api_micro_version], [0])
35 m4_define([modest_api_version], [modest_api_major_version.modest_api_minor_version.modest_api_micro_version])
36
37
38 AC_CONFIG_SRCDIR(src/modest-main.c)
39 AM_INIT_AUTOMAKE([dist-bzip2])
40
41 MODEST_API_MAJOR_VERSION=modest_api_major_version
42 MODEST_API_MINOR_VERSION=modest_api_minor_version
43 MODEST_API_MICRO_VERSION=modest_api_micro_version
44 MODEST_API_VERSION=modest_api_version
45 AC_SUBST(MODEST_API_MAJOR_VERSION)
46 AC_SUBST(MODEST_API_MINOR_VERSION)
47 AC_SUBST(MODEST_API_MICRO_VERSION)
48 AC_SUBST(MODEST_API_VERSION)
49
50 ALL_LINGUAS="en_GB"
51
52 MODEST_LOCALE_DIR='$prefix/${DATADIRNAME}/locale'
53 AM_GLIB_DEFINE_LOCALEDIR([MODEST_LOCALE_DIR])
54 AM_GLIB_GNU_GETTEXT
55
56 if test x$prefix = xNONE; then
57    prefix=/usr/local
58 fi
59 AC_SUBST(prefix)
60
61 AC_PROG_CC
62 AC_PROG_CXX
63 AM_PROG_CC_STDC
64 AC_HEADER_STDC
65 AC_PROG_LIBTOOL
66
67
68 # Option to enable debugging
69 AC_ARG_ENABLE(debug,
70               [AC_HELP_STRING([--enable-debug],[Debugging (default=no)])],
71               [with_debug=yes], [with_debug=no])
72
73 if test "x$with_debug" == "xyes" ; then
74         CFLAGS="$CFLAGS -ggdb -O0 -DDEBUG -Wall"
75 else
76         CFLAGS="$CFLAGS -O2 -Wall"
77 fi
78
79 # Option to enable debugging
80 AC_ARG_ENABLE(gcov,
81               [AC_HELP_STRING([--enable-gcov],[Coverage reporting (default=no)])],
82               [with_gcov=yes], [with_gcov=no])
83
84 if test "x$with_gcov" == "xyes" ; then
85         CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"
86         LDFLAGS="$LDFLAGS -lgcov"
87 fi
88
89
90
91 dnl -------
92 dnl GtkHTML
93 dnl -------
94
95 AC_MSG_CHECKING(for installed version of libgtkhtml3)
96 pkg-config --exists libgtkhtml-3.14
97 retval=$?
98 gtk_html_found=false
99 if test $retval -eq 0 ; then
100     gtk_html_found=true
101     gtk_html_version=3.14
102 else
103     pkg-config --exists libgtkhtml-3.8
104     retval=$?
105     if test $retval -eq 0 ; then
106       gtk_html_found=true
107       gtk_html_version=3.8
108     else
109           if [ $gui = "true" ]; then
110             AC_MSG_RESULT(libgtkhtml 3.4 or higher is not found!)
111           fi
112     fi
113 fi
114
115 if [ $gtk_html_found = "true" ]; then
116    version=`pkg-config --modversion libgtkhtml-${gtk_html_version}`
117    AC_MSG_RESULT(found version $version)
118 else
119    AC_MSG_ERROR([install gtkhtml 3.8 or newer])
120 fi
121
122
123 dnl # GLib/Gobject/Gtk/Gconf => mandatory
124
125 PKG_CHECK_MODULES(MODEST_GSTUFF,glib-2.0 >= 2.6 gobject-2.0 gtk+-2.0 >= 2.6 gconf-2.0 gnome-vfs-2.0 libgtkhtml-${gtk_html_version} libtinymail-1.0 libtinymail-camel-1.0 libtinymail-gnomevfs-1.0 libtinymailui-1.0 libtinymailui-gtk-1.0) 
126 AC_SUBST(MODEST_GSTUFF_CFLAGS)
127 AC_SUBST(MODEST_GSTUFF_LIBS)
128
129 modest_save_cflags="$CFLAGS"
130 modest_save_libs="$LIBS"
131 PKG_CHECK_MODULES(MODEST_GTKHTML,libgtkhtml-${gtk_html_version})
132 AC_SUBST(MODEST_GTKHTML_CFLAGS)
133 AC_SUBST(MODEST_GTKHTML_LIBS)
134 CFLAGS="$MODEST_GTKHTML_CFLAGS"
135 LIBS="$MODEST_GTKHTML_LIBS"
136 AC_CHECK_DECLS([gtk_widget_tap_and_hold_setup],[],[], [#include <gtk/gtk.h>])
137 AC_CHECK_FUNCS(gtk_html_get_selection_area)
138 AC_SUBST(HAVE_GTK_HTML_GET_SELECTION_AREA)
139 AC_CHECK_FUNCS(gtk_tree_view_column_get_cell_data_hint)
140 AC_SUBST(HAVE_GTK_TREE_VIEW_COLUMN_GET_CELL_DATA_HINT)
141 CFLAGS="$modest_save_cflags"
142 LIBS="$modest_save_libs"
143
144
145 dnl dnl now, determine what to build
146 dnl AC_MSG_NOTICE([Determining what platform to build])
147 PKG_CHECK_MODULES(MODEST_MAEMO_LIBS,conic,[detected_platform=maemo],[detected_platform=gnome])
148
149 AC_ARG_WITH(platform, [
150 Target platform:
151   --with-platform=detect  detect target platform (default)
152   --with-platform=gnome   build for Gnome
153   --with-platform=maemo   build for Maemo
154 ],
155 [case "${with_platform}" in
156        gnome|maemo|detect)    MODEST_PLATFORM=${with_platform};;
157        *)        AC_MSG_ERROR([Unknown platform selected]);;
158 esac], [MODEST_PLATFORM=detect])
159
160 if test "$MODEST_PLATFORM" = "detect"; then
161         MODEST_PLATFORM="$detected_platform"
162         with_platform=$detected_platform
163 fi
164
165 if test "$with_platform" = "maemo"; then
166         MODEST_PLUGIN_DEFINES=" -DMODEST_PLATFORM_MAEMO -DMODEST_API_VERSION=${MODEST_API_VERSION}"
167 elif test "$with_platform" = "gnome"; then
168         MODEST_PLUGIN_DEFINES=" -DMODEST_PLATFORM_GNOME -DMODEST_API_VERSION=${MODEST_API_VERSION}"
169 fi
170 AC_SUBST(MODEST_PLUGIN_DEFINES)
171
172 #
173 # check the widgets library
174 #
175 have_hildon2=false
176 have_hildon1=false
177 have_hildon0=false
178 have_gtk=false
179 PKG_CHECK_EXISTS(hildon-1, have_hildon1=true,have_hildon1=false)
180 if test "$have_hildon1" = "true"; then
181    PKG_CHECK_EXISTS(hildon-1 >= 2.1.0, have_hildon2=true, have_hildon2=false)
182    PKG_CHECK_MODULES(MODEST_HILDON_WIDGETS,hildon-1 hildon-fm-2)
183    hildonpkgs="hildon-1 hildon-fm-2"
184    detected_toolkit=hildon1
185    echo "DETECTED HILDON 1 $have_hildon2."
186 else
187    hildonpkgs="hildon-libs hildon-fm"
188    detected_toolkit=hildon1
189    PKG_CHECK_EXISTS(hildon-libs >= 0.12.0, have_hildon1=true, have_hildon1=false)
190    if test "$have_hildon1" = "false"; then
191       PKG_CHECK_EXISTS(hildon-libs, have_hildon0=true, have_hildon0=false)
192       if test "$have_hildon0" = "false"; then
193          have_gtk=true
194          detected_toolkit=gtk
195          hildonpkgs=
196       fi
197    fi
198    if test "$have_gtk" = "false"; then
199       PKG_CHECK_MODULES(MODEST_HILDON_WIDGETS,hildon-libs hildon-fm)
200    fi
201 fi
202
203 dnl --------------- HILDON & PLUGIN PKGS -----------
204 pluginpkgs=$hildonpkgs
205 echo "Plugin Packages $pluginpkgs"
206 AC_SUBST(pluginpkgs)
207
208 # Plugin packages must not include libcanberra and libprofile
209 if test "$have_hildon2" = "true"; then
210    echo "DETECTED HILDON 2 $have_hildon2."
211    detected_toolkit=hildon2
212    hildonpkgs="$hildonpkgs libcanberra profile"
213    echo "HILDON 2 PACKAGES $hildonpkgs"
214    AC_CHECK_HEADER([profiled/keys_nokia.h], [], AC_MSG_ERROR([You have to install package profile-data-dev]))
215 fi
216 AC_SUBST(hildonpkgs)
217
218 dnl --------------- HILDON API ------------
219 hildon_api=
220 if test "$have_hildon0" = "true"; then
221    hildon_api=0
222 elif test "$have_hildon1" = "true"; then
223    hildon_api=1
224 elif test "$have_gtk" = "false"; then
225    hildon_api=`$PKG_CONFIG --modversion hildon-1 | cut -d. -f1`
226 fi
227
228 AC_DEFINE_UNQUOTED(MODEST_HILDON_API, $hildon_api, ["the API version of hildon"])
229 MODEST_PLUGIN_DEFINES="$MODEST_PLUGIN_DEFINES -DMODEST_HILDON_API=$hildon_api"
230
231 AC_ARG_WITH(toolkit, [
232 Target toolkit:
233   --with-toolkit=detect  detect target toolkit (default)
234   --with-toolkit=gtk   build for Gnome
235   --with-toolkit=hildon1   build for Hildon 1.x
236   --with-toolkit=hildon2   build for Hildon 2.x
237 ],
238 [case "${with_toolkit}" in
239        gtk|hildon1|hildon2|detect)    MODEST_TOOLKIT=${with_toolkit};;
240        *)        AC_MSG_ERROR([Unknown platform selected]);;
241 esac], [MODEST_TOOLKIT=detect])
242
243 if test "$MODEST_TOOLKIT" = "detect"; then
244         MODEST_TOOLKIT="$detected_toolkit"
245         with_toolkit=$detected_toolkit
246 fi
247
248 if test "$with_toolkit" = "hildon1"; then
249         MODEST_PLUGIN_DEFINES="$MODEST_PLUGIN_DEFINES -DMODEST_TOOLKIT_HILDON1"
250 elif test "$with_toolkit" = "hildon2"; then
251         MODEST_PLUGIN_DEFINES="$MODEST_PLUGIN_DEFINES -DMODEST_TOOLKIT_HILDON2"
252 elif test "$with_toolkit" = "gtk"; then
253         MODEST_PLUGIN_DEFINES="$MODEST_PLUGIN_DEFINES -DMODEST_TOOLKIT_GNOME"
254 fi
255
256 dnl Whether to use maemo-launcher or not
257 AC_ARG_ENABLE([maemo-launcher],
258               [AS_HELP_STRING([--enable-maemo-launcher],
259                               [build with maemo-launcher support])],
260                               [case "${enableval}" in
261                                yes) maemo_launcher=true ;;
262                                no)  maemo_launcher=false ;;
263                                *) AC_MSG_ERROR([bad value ${enableval} for --enable-maemo-launcher]) ;;
264                                esac], [maemo_launcher=false])
265 if test x$maemo_launcher = xtrue
266 then
267         PKG_CHECK_MODULES(MAEMO_LAUNCHER, [maemo-launcher-app])
268         AC_SUBST(MAEMO_LAUNCHER_CFLAGS)
269         AC_SUBST(MAEMO_LAUNCHER_LIBS)
270 fi
271
272 have_easysetup=false
273 if test "x$with_toolkit" == "xgtk"; then
274    PKG_CHECK_MODULES(MODEST_TOOLKIT,glib-2.0 >= 2.8 gtk+-2.0 >= 2.10 libnotify)
275    AC_DEFINE_UNQUOTED(MODEST_TOOLKIT_GTK, 1, ["Whether modest is being build for the gtk toolkit."])
276    MODEST_TOOLKIT_DIR=gnome
277 else
278    have_easysetup=true
279    PKG_CHECK_MODULES(MODEST_TOOLKIT,$hildonpkgs)
280    if test "$with_toolkit" = "hildon2"; then
281       AC_DEFINE_UNQUOTED(MODEST_TOOLKIT_HILDON2, 1, ["Whether modest is being build for the hildon2 toolkit."])
282       MODEST_TOOLKIT_DIR=hildon2
283    else
284       AC_DEFINE_UNQUOTED(MODEST_TOOLKIT_HILDON1, 1, ["Whether modest is being build for the hildon2 toolkit."])
285       MODEST_TOOLKIT_DIR=maemo
286    fi
287     AC_DEFINE_UNQUOTED(MODEST_HAVE_EASYSETUP, 1, ["Whether we have the easysetup feature"])
288 fi
289 AM_CONDITIONAL(MODEST_HAVE_EASYSETUP,test "x$have_easysetup" == "xtrue")
290 AC_SUBST(MODEST_TOOLKIT)
291 AC_SUBST(MODEST_TOOLKIT_DIR)
292
293 if test "x$with_platform" == "xgnome"; then
294       PKG_CHECK_MODULES(MODEST_PLATFORM,libtinymail-gnome-desktop-1.0 glib-2.0 >= 2.8 libnotify)
295     AC_DEFINE_UNQUOTED(MODEST_PLATFORM_GNOME, 1, ["Whether modest is being built for the GNOME platform."])
296 dnl     AC_MSG_ERROR([The GNOME Build is currently broken; please try the Maemo build instead])
297 else
298     have_dbusapi=true
299     PKG_CHECK_MODULES(MODEST_PLATFORM,libosso dbus-1 libtinymail-maemo-1.0 libebook-1.2 )
300     AC_DEFINE_UNQUOTED(MODEST_PLATFORM_MAEMO, 1, ["Whether modest is being built for the MAEMO platform."])
301 fi
302 AM_CONDITIONAL(MODEST_HAVE_DBUS_API,test "x$have_dbusapi" == "xtrue")
303 AC_SUBST(MODEST_PLATFORM)
304
305
306
307 #
308 # check for wpeditor or libwpeditor-plus (on maemo)
309 #
310 if test "x$with_toolkit" != "xgtk"; then  
311 PKG_CHECK_MODULES(MODEST_WPEDITOR,wpeditor,have_wpeditor=true,have_wpeditor=false)
312 if test "x$have_wpeditor" == "xfalse"; then
313    PKG_CHECK_MODULES(MODEST_WPEDITOR,libwpeditor-plus,have_libwpeditorplus=true,have_libwpeditorplus=false)     
314    if test "x$have_libwpeditorplus" == "xtrue"; then
315         wpeditor="libwpeditor-plus"
316         AC_DEFINE_UNQUOTED(MODEST_HAVE_LIBWPEDITOR_PLUS, 1, ["Whether libwpeditor-plus is used."])              
317    else
318         AC_MSG_ERROR([you need to have either wpeditor or libwpeditor-plus installed])
319    fi
320 else
321    wpeditor="wpeditor"  
322    AC_DEFINE_UNQUOTED(MODEST_HAVE_WPEDITOR, 1, ["Whether wpeditor is used."])           
323 fi
324 fi
325
326
327 #
328 # check libalarm
329 #
330 if test "x$with_platform" == "xmaemo"; then  
331    PKG_CHECK_MODULES(MODEST_LIBALARM,libalarm,have_libalarm=true,have_libalarm=false)
332    if test "x$have_libalarm" == "xfalse"; then
333       PKG_CHECK_MODULES(MODEST_LIBALARM, alarm, have_libalarm=true,have_libalarm=false)
334    fi
335    if test "x$have_libalarm" == "xtrue"; then
336       AC_DEFINE_UNQUOTED(MODEST_HAVE_LIBALARM, 1, ["Whether libalarm is used."])                
337       AC_SUBST(MODEST_LIBALARM_CFLAGS)
338       AC_SUBST(MODEST_LIBALARM_LIBS)
339    fi
340 fi
341
342 #
343 # check for MCE
344 #
345 if test "x$with_platform" == "xmaemo"; then  
346 PKG_CHECK_MODULES(MODEST_MCE,mce,have_mce=true,have_mce=false)
347 if test "x$have_mce" == "xtrue"; then
348    mce="mce"    
349    AC_DEFINE_UNQUOTED(MODEST_HAVE_MCE, 1, ["Whether mce is used."])
350    AC_SUBST(MODEST_MCE_CFLAGS)
351    AC_SUBST(MODEST_MCE_LIBS)
352 else
353    mce=""
354 fi
355 fi
356
357 #
358 # check for libconic; this is a trick to check whether we run
359 # on a 'real' maemo platform, or on, say, ubuntu embedded
360 # this determines whether we build with the non-hildon GTK+
361 #
362 if test "x$with_platform" == "xmaemo"; then  
363 PKG_CHECK_MODULES(MODEST_LIBCONIC,conic,have_libconic=true,have_libconic=false)
364 if test "x$have_libconic" == "xtrue"; then
365    AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_GTK,1,["Whether modest is being built with Hildon/Gtk"])
366    AC_DEFINE_UNQUOTED(MODEST_HAVE_CONIC,1,["Whether modest has conic available"])
367    AC_SUBST(MODEST_LIBCONIC_CLAGS)
368    AC_SUBST(MODEST_LIBCONIC_LIBS)
369 else
370 # if we define this, tinymail will not try to #include conic headers
371    CFLAGS="$CFLAGS -DLIBTINYMAIL_MAEMO_WITHOUT_CONIC"
372 fi
373 fi
374
375 #
376 # check hildon-help (only for maemo AND NOT fremantle)
377 #
378 if test "x$with_toolkit" == "xhildon1"; then
379    PKG_CHECK_MODULES(MODEST_HILDON_HELP,hildon-help,have_hildon_help=true,have_hildon_help=false)
380    if test "x$have_hildon_help" == "xfalse"; then
381       PKG_CHECK_MODULES(MODEST_HILDON_HELP,libossohelp,have_osso_help=true,have_osso_help=false)        
382       if test "x$have_osso_help" == "xtrue"; then
383         helplib="osso-help"
384         AC_DEFINE_UNQUOTED(MODEST_HAVE_OSSO_HELP, 1, ["Whether osso-help is used."])            
385       else
386         AC_MSG_ERROR([you need to have either osso-help or hildon-help installed])
387       fi
388    else
389      helplib="hildon-help"
390      AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_HELP, 1, ["Whether hildon-help is used."])           
391    fi
392 fi
393
394
395
396 #
397 # check for the notification stuff (only maemo)
398 #
399 if test "x$with_toolkit" != "xgtk"; then  
400    PKG_CHECK_MODULES(MODEST_HILDON_NOTIFY,hildon-notify libnotify,have_hildon_notify=true,have_hildon_notify=false)
401    if test "x$have_hildon_notify" == "xtrue"; then
402       AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_NOTIFY, 1, ["Whether hildon-notify is available"])      
403    fi
404 fi
405
406
407 #
408 # check for the uri/mime stuff
409 #
410 if test "x$with_toolkit" != "xgtk"; then  
411    PKG_CHECK_MODULES(MODEST_HILDON_MIME,libhildonmime,have_hildonmime=true,have_hildonmime=false)
412    if test "x$have_hildonmime" == "xfalse"; then
413       PKG_CHECK_MODULES(MODEST_HILDON_MIME,libossomime,have_ossomime=true,have_ossomime=false)  
414       if test "x$have_ossomime" == "xtrue"; then
415         mimelib="osso-mime"
416         AC_DEFINE_UNQUOTED(MODEST_HAVE_OSSO_MIME, 1, ["Whether osso-mime is used."])            
417       else
418         AC_MSG_ERROR([you need to have either osso-mime or hildon-mime installed])
419       fi
420    else
421      mimelib="hildon-mime"      
422      AC_DEFINE_UNQUOTED(MODEST_HAVE_HILDON_MIME, 1, ["Whether hildon-mime is used."])           
423    fi
424 fi
425
426 PKG_CHECK_MODULES(MODEST_MOZEMBED, libtinymailui-mozembed-1.0, have_mozembed=true, have_mozembed=false)
427 AC_ARG_ENABLE(mozembed,
428 AC_HELP_STRING([--enable-mozembed],
429         [Build with GtkMozEmbed (yes, no)]),
430 [case "${enableval}" in
431       yes)
432         if test x$have_mozembed = xfalse; then
433            AC_MSG_ERROR([building of GtkMozEmbed support requested and gtkmozembed not found])
434         fi
435         use_mozembed=true
436         ;;
437       *)
438         use_mozembed=false
439         ;;
440 esac],[use_mozembed=false])
441
442 AM_CONDITIONAL(BUILD_MOZEMBED, test x$use_mozembed = xtrue)
443
444 if test x$use_mozembed = xtrue; then
445         AC_DEFINE_UNQUOTED(MODEST_USE_MOZEMBED, 1, ["Whether we use GtkMozEmbed."])
446 fi
447
448 #dnl wether we can and should build the 
449 #dnl search plugin (on maemo)
450 if test "x$with_platform" == "xmaemo"; then  
451 PKG_CHECK_MODULES(MODEST_OGS, libosso >= 0.8.5 libogs-1.2, have_ogs=true, have_ogs=false)
452 have_ogs_support=false
453 AC_ARG_ENABLE(ogs_support,
454 AC_HELP_STRING([--enable-ogs-support],
455         [Build with osso global search support (yes, no)]),
456 [case "${enableval}" in
457       yes)
458         if test x$have_ogs = xfalse; then
459            AC_MSG_ERROR([building of ogs support requested and libogs-1.2 not found])
460         fi
461         ;;
462       *) 
463         have_ogs_support=false
464         ;;
465 esac],[have_ogs_support=$have_ogs])
466
467 if test x$have_ogs_support = xtrue; then
468         AC_DEFINE_UNQUOTED(MODEST_HAVE_OGS, 1, ["Whether ogs is available."])
469 fi
470 fi
471
472
473
474
475 #
476 # check the version of the addressbook on maemo
477 #
478 if test "x$with_platform" == "xmaemo"; then  
479    PKG_CHECK_MODULES(MODEST_ABOOK,osso-addressbook-1.0,have_abook=true,have_abook=false)
480    abook_api=`$PKG_CONFIG --modversion osso-addressbook-1.0 | cut -d. -f1`
481    AC_SUBST(MODEST_ABOOK_CFLAGS)
482    AC_SUBST(MODEST_ABOOK_LIBS)
483
484    if test "x$have_abook" == "xfalse"; then
485      PKG_CHECK_MODULES(MODEST_ABOOK, libosso-abook-1.0,have_abook=true,have_abook=false)
486      abook_api=`$PKG_CONFIG --modversion libosso-abook-1.0 | cut -d. -f1`
487      AC_SUBST(MODEST_ABOOK_CFLAGS)
488      AC_SUBST(MODEST_ABOOK_LIBE)
489    fi
490
491    if test "x$have_abook" == "xtrue"; then
492       AC_DEFINE_UNQUOTED(OSSO_ABOOK_ENABLE_DEPRECATED, 1, ["use deprecated addressbook API"])
493       AC_DEFINE_UNQUOTED(MODEST_ABOOK_API, $abook_api, ["the API version of osso-addressbook"])
494       AC_DEFINE_UNQUOTED(MODEST_HAVE_ABOOK, 1, ["whether we have osso-addressbook"])
495       addressbook="osso-addressbook"
496    fi
497 fi
498
499
500 #
501 # if we don't have an addressbook, use the dummy one
502 #
503 AM_CONDITIONAL(MODEST_USE_DUMMY_ADDRESS_BOOK,test "x$have_abook" != "xtrue")
504
505
506 AM_GLIB_GNU_GETTEXT
507 IT_PROG_INTLTOOL([0.35.0])
508
509 # gettext support
510 GETTEXT_PACKAGE=modest  
511 AC_SUBST(GETTEXT_PACKAGE)
512 AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", ["gettext package"])
513
514
515 #
516 # settings for maemo platform
517 #
518 if test "x$with_platform" == "xmaemo"; then  
519
520   # warnings are errors, but don't check format errors, because
521   # it breaks with logical ids
522   CFLAGS="$CFLAGS -Wno-format-extra-args -Werror"
523
524    desktopentrydir=`$PKG_CONFIG osso-af-settings --variable=desktopentrydir`
525    serviceentrydir=`$PKG_CONFIG dbus-glib-1 --variable=prefix`/share/dbus-1/services
526    localedir=`$PKG_CONFIG osso-af-settings --variable=localedir`
527    backupsettingsdir=/etc/osso-backup/applications
528    ossocudscriptsdir=/etc/osso-cud-scripts
529    pixmapdir=`$PKG_CONFIG osso-af-settings --variable=hildonpixmapdir`
530    icon_26x26dir=$datadir/icons/hicolor/26x26/hildon
531    icon_34x34dir=$datadir/icons/hicolor/34x34/hildon
532    icon_40x40dir=$datadir/icons/hicolor/40x40/hildon
533    icon_50x50dir=$datadir/icons/hicolor/50x50/hildon
534    icon_scalabledir=$datadir/icons/hicolor/scalable/hildon
535    pluginlibdir=`$PKG_CONFIG hildon-control-panel --variable=plugindir`
536    plugindesktopentrydir=`$PKG_CONFIG hildon-control-panel --variable=plugindesktopentrydir`
537
538    dbus_api="dbus_api"
539    AC_SUBST(dbus_api)
540
541    # Define as variables in Makefiles
542    AC_SUBST(desktopentrydir)
543    AC_SUBST(serviceentrydir)
544    AC_SUBST(backupsettingsdir)
545    AC_SUBST(ossocudscriptsdir)
546    AC_SUBST(localedir)
547    AC_SUBST(pixmapdir)
548    AC_SUBST(icon_26x26dir)
549    AC_SUBST(icon_34x34dir)
550    AC_SUBST(icon_40x40dir)
551    AC_SUBST(icon_50x50dir)
552    AC_SUBST(icon_scalabledir)
553    AC_SUBST(pluginlibdir)
554    AC_SUBST(plugindesktopentrydir)
555
556 fi
557
558 dnl ## setup the testing framework (ie., make check)
559 build_tests=false
560 AC_ARG_ENABLE(tests,
561 AC_HELP_STRING([--enable-tests],
562         [Build tests (no, yes)]),
563 [case "${enableval}" in
564       yes)
565         build_tests=true ;;
566       *) build_tests=false ;;
567 esac],[build_tests=false])
568 AM_CONDITIONAL(BUILD_TESTS, test x$build_tests = xtrue)
569
570
571
572 dnl ## is the check package installed?
573 if test x$build_tests = xtrue; then
574    PKG_CHECK_MODULES(CHECK, check >= 0.9.4 glib-2.0)
575 fi
576
577
578
579 dnl ## do we want documentation (gtk-doc)
580 build_docs=false
581 AC_ARG_ENABLE(docs,
582 AC_HELP_STRING([--enable-docs],
583         [Build documentation (yes, no)]),
584 [case "${enableval}" in
585       yes)
586         build_docs=true ;;
587       *) build_docs=false ;;
588 esac],[build_docs=false])
589 AM_CONDITIONAL(BUILD_DOCS, test x$build_docs = xtrue)
590
591 dnl ## gtk-doc
592 GTK_DOC_CHECK([1.0])
593
594 AC_OUTPUT([
595 po/Makefile.in
596 Makefile
597 man/Makefile
598 src/Makefile
599 src/modest-plugin-1.0.pc
600 src/dbus_api/Makefile
601 src/gnome/Makefile
602 src/maemo/Makefile
603 src/maemo/easysetup/Makefile
604 src/hildon2/Makefile
605 src/widgets/Makefile
606 docs/Makefile
607 docs/reference/Makefile
608 tests/Makefile
609 tests/dbus_api/Makefile
610 src/maemo/modest.desktop
611 src/maemo/com.nokia.modest.service
612 src/hildon2/modest.desktop
613 src/hildon2/com.nokia.modest.service
614 libmodest-dbus-client/Makefile
615 libmodest-dbus-client/libmodest-dbus-client-1.0.pc
616 ])
617
618
619 echo
620 echo "modest configure results"
621 echo "-----------------------------------"
622 echo "Platform         : $with_platform"
623 echo "Toolkit          : $with_toolkit"
624 echo "Prefix           : ${prefix}"
625 echo "Build tests      : $build_tests"
626 echo "Build docs       : $build_docs"
627 echo "Gettext Package  : $GETTEXT_PACKAGE"
628
629 if test "x$with_platform" == "xmaemo"; then
630    echo "Maemo Launcher   : $maemo_launcher"
631    echo "Editor lib       : $wpeditor"
632    echo "Addressbook      : $have_abook"
633    if test "x$with_toolkit" == "xhildon1"; then
634       echo "Help lib         : $helplib"
635    fi
636    echo "libconic support : $have_libconic"
637    echo "Alarm            : $have_libalarm"
638    echo "MCE              : $have_mce"
639    echo "Hildon-Notify    : $have_hildon_notify"
640    echo "LibOGS support   : $have_ogs_support"
641 fi
642
643 echo "MozEmbed support : $use_mozembed"
644 if [ $gtk_html_found = "true" ]; then
645    echo "GtkHTML version  : $gtk_html_version"
646 fi
647
648 echo "CFLAGS           : $CFLAGS"
649 echo "Debug version    : $with_debug"
650 echo ""
651 echo "NOTE: you should do a 'make clean' after changing architecture or platform (--with-platform=)"
652 echo ""