Properly use export.map, to limit the number of symbols exported
[modest] / src / Makefile.am
index bc5e920..5a50eff 100644 (file)
@@ -208,7 +208,7 @@ modest_LDADD = \
        ${easysetupmaybe}                               \
        libmodest.la)
 
-modest_LDFLAGS = -export-dynamic -Wl,--version-script=export.map
+modest_LDFLAGS = -shared -Wl,--version-script=export.map
 
 # modest_UNWANTED = -export-dynamic -Wl,--export-dynamic