compiles, packages, installs as daemon
[nowplayingd] / debian / rules
index 7059586..f0f20f9 100755 (executable)
@@ -27,9 +27,10 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       # $(MAKE)
        #docbook-to-man debian/nowplayingd.sgml > nowplayingd.1
-
+       gcc -Wall `pkg-config --cflags --libs hildon-notify glib-2.0 mafw mafw-shared` nowplaying.c -o nowplayingd
+       
        touch $@
 
 clean: 
@@ -38,18 +39,22 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
+       # $(MAKE) clean
 
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_prep  
        dh_installdirs
 
        # Add here commands to install the package into debian/nowplayingd.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/nowplayingd install
+       # $(MAKE) DESTDIR=$(CURDIR)/debian/nowplayingd install
+       mkdir -p $(CURDIR)/debian/nowplayingd/usr/bin
+       cp nowplayingd $(CURDIR)/debian/nowplayingd/usr/bin/
+
+       mkdir -p $(CURDIR)/debian/nowplayingd/etc/X11/Xsession.d
+       cp scripts/99nowplayingd $(CURDIR)/debian/nowplayingd/etc/X11/Xsession.d/
 
 
 # Build architecture-independent files here.