Update some gtk stuff, add redundant debug info to hildon-desktop and improve README
[oespirit1] / gtk+ / gtk+_2.12.12.bb
index 52f5edb..9d118b4 100644 (file)
@@ -4,14 +4,13 @@
 
 require gtk+.inc
 
-# Temporary additions for testing
+# Temporary addition for testing
 # to get rid of the vagaries of the 
 # standalone gdk-pixbuf recipe
 PROVIDES = "gdk-pixbuf"
 RPROVIDES = "gdk-pixbuf"
-EXTRA_OECONF += "--with-included-loaders=png,tga --disable-gtk-doc"
 
-PR = "r1"
+PR = "r103"
 
 DEPENDS += "cairo"
 
@@ -19,9 +18,8 @@ DEFAULT_PREFERENCE = 1
 
 S="${WORKDIR}/gtk+2.0-2.12.12"
 
-#FIXME : Patches currently used are only to get the build working. 
-#        After testing on the device,
-#        uncomment the required patches
+#FIXME : Patches currently used are only to get the build working. After testing on the device,
+#uncomment the required patches
 
 SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${PV}-1maemo12+0m5.tar.gz \
            file://gtk+2.0-2.12.12/mer-changes.patch;patch=1 \
@@ -31,7 +29,6 @@ SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${P
 #          file://gtk+2.0-2.12.12/run-iconcache.patch;patch=1 \
 #          file://gtk+2.0-2.12.12/hardcoded_libtool.patch;patch=1 \
            file://gtk+2.0-2.12.12/cellrenderer-cairo.patch;patch=1;pnum=0 \
-#this one really needs to be killed
            file://gtk+2.0-2.12.12/png-use-old-symbol.patch;patch=1;pnum=0 \
            file://gtk+2.0-2.12.12/entry-cairo.patch;patch=1;pnum=0 "
 #           file://gtk+2.0-2.12.12/toggle-font.diff;patch=1;pnum=0 \
@@ -46,6 +43,10 @@ SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${P
 EXTRA_OECONF = "--with-libtiff --with-gdktarget=x11 --disable-xkb --enable-display-migration --disable-gtk-doc --with-maemo=yes --with-libpng --with-libjpeg --with-x "
 
 
+#Used for the gdk-pixbuf stuff
+EXTRA_OECONF += "--with-included-loaders=png,tga --disable-gtk-doc"
+
+
 
 
 LIBV = "2.10.0"
@@ -74,16 +75,20 @@ python populate_packages_prepend () {
                 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
 }
 
+# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require gtk-fpu.inc
+EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
+
+
 PACKAGES += "gdk-pixbuf"
 
 FILES_gdk-pixbuf = " ${bindir}/gdk-pixbuf-query-loaders \
                         ${bindir}/gtk-update-icon-cache \
                         ${libdir}/libgdk*"
 
-# check for TARGET_FPU=soft and inform configure of the result 
-# so it can disable some floating points
-require gtk-fpu.inc
-EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
-
 
 
+# Needed while Testing 
+do_rm_work(){
+    :
+}