Update to 2.0.0 tree from current Fremantle build
[opencv] / otherlibs / _graphics / src / libtiff / Makefile.am
diff --git a/otherlibs/_graphics/src/libtiff/Makefile.am b/otherlibs/_graphics/src/libtiff/Makefile.am
deleted file mode 100644 (file)
index 365e27c..0000000
+++ /dev/null
@@ -1,128 +0,0 @@
-# Tag Image File Format (TIFF) Software
-#
-# Copyright (C) 2004, Andrey Kiselev <dron@remotesensing.org>
-#
-# Permission to use, copy, modify, distribute, and sell this software and 
-# its documentation for any purpose is hereby granted without fee, provided
-# that (i) the above copyright notices and this permission notice appear in
-# all copies of the software and related documentation, and (ii) the names of
-# Sam Leffler and Silicon Graphics may not be used in any advertising or
-# publicity relating to the software without the specific, prior written
-# permission of Sam Leffler and Silicon Graphics.
-# 
-# THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, 
-# EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY 
-# WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.  
-# 
-# IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
-# ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
-# OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
-# WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF 
-# LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE 
-# OF THIS SOFTWARE.
-
-# Process this file with automake to produce Makefile.in.
-
-LIBPORT = -L$(top_builddir)/port -lport
-
-EXTRA_DIST = Makefile.vc tif_config.h.vc tiffconf.h.vc libtiff.def \
-            $(EXTRA_SRCS)
-
-HDRS = \
-       tiff.h \
-        tiffconf.h \
-       tiffio.h \
-       tiffvers.h
-
-if HAVE_CXX
-HDRS +=        tiffio.hxx
-endif
-
-EXTRA_HDRS = \
-       t4.h \
-       tif_dir.h \
-       tif_predict.h \
-       tiffiop.h \
-       uvcode.h
-
-SRCS = \
-       tif_aux.c \
-       tif_close.c \
-       tif_codec.c \
-       tif_color.c \
-       tif_compress.c \
-       tif_dir.c \
-       tif_dirinfo.c \
-       tif_dirread.c \
-       tif_dirwrite.c \
-       tif_dumpmode.c \
-       tif_error.c \
-       tif_extension.c \
-       tif_fax3.c \
-       tif_fax3sm.c \
-       tif_flush.c \
-       tif_getimage.c \
-       tif_jpeg.c \
-       tif_luv.c \
-       tif_lzw.c \
-       tif_next.c \
-       tif_ojpeg.c \
-       tif_open.c \
-       tif_packbits.c \
-       tif_pixarlog.c \
-       tif_predict.c \
-       tif_print.c \
-       tif_read.c \
-       tif_strip.c \
-       tif_swab.c \
-       tif_thunder.c \
-       tif_tile.c \
-       tif_unix.c \
-       tif_version.c \
-       tif_warning.c \
-       tif_write.c \
-       tif_zip.c
-
-SRCSXX = \
-       tif_stream.cxx
-
-EXTRA_SRCS = \
-       tif_acorn.c \
-       tif_apple.c \
-       tif_atari.c \
-       tif_msdos.c \
-       tif_next.c \
-       tif_win3.c \
-       tif_win32.c
-
-libtiffincludedir = $(includedir)
-libtiffinclude_HEADERS = $(HDRS)
-noinst_HEADERS = $(EXTRA_HDRS)
-
-lib_LTLIBRARIES = libtiff.la
-if HAVE_CXX
-lib_LTLIBRARIES += libtiffxx.la
-endif
-
-libtiff_la_SOURCES = $(SRCS)
-libtiff_la_LDFLAGS = \
-       -no-undefined \
-       -version-number $(LIBTIFF_MAJOR_VERSION):$(LIBTIFF_MINOR_VERSION):$(LIBTIFF_MICRO_VERSION)
-
-libtiffxx_la_SOURCES = $(SRCSXX)
-libtiffxx_la_LDFLAGS = \
-       -no-undefined \
-       -version-number $(LIBTIFF_MAJOR_VERSION):$(LIBTIFF_MINOR_VERSION):$(LIBTIFF_MICRO_VERSION)
-
-#
-# The finite state machine tables used by the G3/G4 decoders
-# are generated by the mkg3states program.  On systems without
-# make these rules have to be manually carried out.
-#
-noinst_PROGRAMS = mkg3states
-mkg3states_SOURCES = mkg3states.c tif_fax3.h
-mkg3states_LDADD = $(LIBPORT)
-
-faxtable: mkg3states
-       (rm -f tif_fax3sm.c && ./mkg3states -b -c const tif_fax3sm.c)
-