Debian lenny version packages
[pkg-perl] / deb-src / libio-compress-base-perl / libio-compress-base-perl-2.012 / debian / rules
diff --git a/deb-src/libio-compress-base-perl/libio-compress-base-perl-2.012/debian/rules b/deb-src/libio-compress-base-perl/libio-compress-base-perl-2.012/debian/rules
new file mode 100755 (executable)
index 0000000..da8d606
--- /dev/null
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+# This debian/rules file is provided as a template for normal perl
+# packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
+# the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
+# be used freely wherever it is useful.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# If set to a true value then MakeMaker's prompt function will
+# always return the default without waiting for user input.
+export PERL_MM_USE_DEFAULT=1
+
+PERL   ?= /usr/bin/perl
+PACKAGE = $(shell dh_listpackages)
+TMP     = $(CURDIR)/debian/$(PACKAGE)
+
+build: build-stamp
+build-stamp:
+       dh build --before auto_configure
+       $(PERL) Makefile.PL INSTALLDIRS=vendor INST_LIB='blib/lib'
+       dh build --after auto_configure
+       touch $@
+
+clean:
+       dh $@
+
+install: install-stamp
+install-stamp: build-stamp
+       dh install --before auto_install
+       $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
+       pod2man --section 3pm --name "IO::Compress::Base::FAQ" pod/FAQ.pod \
+               > $(TMP)/usr/share/man/man3/IO::Compress::Base::FAQ.3pm
+       dh install --after auto_install
+       touch $@
+
+binary-arch:
+# We have nothing to do here for an architecture-independent package
+
+binary-indep: install
+       dh $@
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install