Very rough initial implementation of torrent adding working.
[qtrapids] / src / qml-client / CMakeLists.txt
index a9d4dbc..68ce22b 100644 (file)
@@ -24,7 +24,9 @@ INCLUDE_DIRECTORIES(
 
 SET_SOURCE_FILES_PROPERTIES(${CMAKE_CURRENT_SOURCE_DIR}/proxy.cpp ${CMAKE_CURRENT_SOURCE_DIR}/proxy.h PROPERTIES GENERATED 1)
 
+# TODO: Use proxy from dedicated directory, so we don't generate them in all client dirs.
 SET(MOC_HEADERS
+    ./proxy.h
     ./MainPageHandler.h
     ./models/QDeclarativeDownloadListModel.h
     ./models/QDeclarativeDownloadListModel_p.h
@@ -32,6 +34,7 @@ SET(MOC_HEADERS
 
 SET(SRC
     ./main.cpp
+    ./proxy.cpp
     ./MainPageHandler.cpp
     ./models/QDeclarativeDownloadListModel.cpp
 )