Added TorrentPickerPage.
[qtrapids] / src / qml-client / CMakeLists.txt
index 873b699..a9d4dbc 100644 (file)
@@ -19,31 +19,21 @@ INCLUDE_DIRECTORIES(
    ${QT_QTDBUS}
    ${QT_QTGUI}
    ${QT_QTDECLARATIVE_INCLUDE_DIR}
+    /usr/include/meegotouch
 )
 
 SET_SOURCE_FILES_PROPERTIES(${CMAKE_CURRENT_SOURCE_DIR}/proxy.cpp ${CMAKE_CURRENT_SOURCE_DIR}/proxy.h PROPERTIES GENERATED 1)
 
 SET(MOC_HEADERS
+    ./MainPageHandler.h
     ./models/QDeclarativeDownloadListModel.h
     ./models/QDeclarativeDownloadListModel_p.h
-#     ./DownloadView.h
-#     ./models/Plugin.h
-#   ./MainWindow.h
-#   ./PreferencesDialog.h
-#   ./proxy.h
-#   ./SeedView.h
-#   ./ColumnSelectorDialog.h
 )
 
 SET(SRC
-#     ./DownloadView.cpp
     ./main.cpp
+    ./MainPageHandler.cpp
     ./models/QDeclarativeDownloadListModel.cpp
-#   ./MainWindow.cpp
-#   ./PreferencesDialog.cpp
-#   ./proxy.cpp
-#   ./SeedView.cpp
-#   ./ColumnSelectorDialog.cpp
 )
 
 
@@ -83,6 +73,7 @@ TARGET_LINK_LIBRARIES(qml-client
   ${QT_QTTEST_LIBRARY}
   ${QT_QTDECLARATIVE_LIBRARY}
   -lboost_system-mt
+  -lmeegotouchcore
 )
 
 # Check if we are building under scratchbox and link with QtMaemo5 only in that case.