pcremote-client-n8x0 -> client sources
[remotepc] / pcremote-server-desktop-60 / debian / rules
diff --git a/pcremote-server-desktop-60/debian/rules b/pcremote-server-desktop-60/debian/rules
deleted file mode 100755 (executable)
index f45b7f5..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/usr/bin/make -f
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
-       ##$(MAKE)
-       #docbook-to-man debian/pcremote-server.sgml > pcremote-server.1
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       dh_clean
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-       dh_installmenu
-       dh_icons
-       # Add here commands to install the package into debian/pcremote-server.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/pcremote-server
-       mkdir -p $(CURDIR)/debian/pcremote-server
-
-        ###insert your commands here
-       cp *.py $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r exceptions/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r images/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r services/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r players/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r connection/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-       cp -r utils/ $(CURDIR)/debian/pcremote-server/usr/share/pcremote-server
-
-       ### Installing menufile
-       # copy the file with the menu entry into /usr/share/applications
-       cp pcremote-server.desktop $(CURDIR)/debian/pcremote-server/usr/share/applications
-       cp pcremote.png $(CURDIR)/debian/pcremote-server/usr/share/icons 
-       cp pcremote-server-menu $(CURDIR)/debian/pcremote-server/usr/share/menu
-       cp pcremote-server $(CURDIR)/debian/pcremote-server/usr/bin
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-#      dh_install
-       dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure