initial import
[slovak-l10n] / ukeyboard / debian / rules
diff --git a/ukeyboard/debian/rules b/ukeyboard/debian/rules
new file mode 100755 (executable)
index 0000000..ce18cac
--- /dev/null
@@ -0,0 +1,71 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DESTDIR=$(CURDIR)/debian/ukeyboard
+DESTDIR_CREATOR=$(CURDIR)/debian/ukbdcreator
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+
+#      for OS2008
+#      $(MAKE)
+#      for Maemo5
+       CFLAGS="$(CFLAGS) -DHAVE_MAEMO5" $(MAKE)
+
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # Add here commands to clean up after the build process.
+       $(MAKE) clean
+
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+
+       # Add here commands to install the package into $(DESTDIR)
+       $(MAKE) DESTDIR=$(DESTDIR) install
+       $(MAKE) -C ukbdcreator DESTDIR=$(DESTDIR_CREATOR)/usr install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+#      dh_installchangelogs 
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure