Initial revision
[monky] / app-admin / conky / conky-1.2.ebuild
1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 inherit eutils
6
7 DESCRIPTION="minimalist system monitor for X based on torsmo"
8 HOMEPAGE="http://conky.rty.ca"
9 SRC_URI="http://conky.rty.ca/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti metar"
15
16 RDEPEND="virtual/libc
17         virtual/x11
18         truetype? ( >=media-libs/freetype-2 )
19         seti? ( sci-astronomy/setiathome )
20         metar? ( dev-libs/mdsplib )"
21
22 DEPEND="truetype? ( >=media-libs/freetype-2 )
23         virtual/x11
24         >=sys-devel/automake-1.4
25         sys-devel/autoconf
26         sys-apps/grep
27         sys-apps/sed
28         sys-devel/gcc
29         >=sys-process/procps-3.2.5
30         "
31
32
33 src_compile() {
34         local myconf
35         myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime
36         --enable-mpd"
37         econf \
38            ${myconf} \
39            $(use_enable truetype xft) \
40            $(use_enable metar) \
41            $(use_enable seti) || die "econf failed"
42         emake || die "compile failed"
43 }
44
45 src_install() {
46         emake DESTDIR=${D} install || die "make install failed"
47         dodoc ChangeLog AUTHORS README conkyrc.sample
48 }
49
50 pkg_postinst() {
51         einfo 'default configuration file is "~/.conkyrc"'
52         einfo "you can find a sample configuration file in"
53         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
54         einfo
55         einfo "For more info on Conky's new features,"
56         einfo "please look at the README and ChangeLog:"
57         einfo "/usr/share/doc/${PF}/README.gz"
58         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
59         einfo
60         einfo "Comment out temperature info lines if you have no kernel"
61         einfo "support for it."
62         einfo
63         ewarn "Conky doesn't work with window managers that"
64         ewarn "take control over root window such as Gnome's nautilus."
65 }