2008-10-10 Claudio Saavedra <csaavedra@igalia.com>
[hildon] / debian / changelog
index ff5dcfa..2f56300 100644 (file)
@@ -1,3 +1,173 @@
+libhildon (2.1.14-1) unstable; urgency=low
+
+  * Switch the build system to use cdbs.
+  * Add --disable-deprecated configure option.
+
+  Bug fixes:
+
+  * Fixes: NB#88644 (Hardcoded first column of the model as text column)
+  * Fixes: NB#89329 (selectors in picker dialog are not visible when a
+    long text is set as label for done button)
+  * Fixes: NB#89651 (HildonTouchSelectorEntry title is <unnamed>, when
+    entry is empty)
+  * Fixes: NB#89632 (Picker button selection doesn't change on first click)
+  * Fixes: NB#88946 (Hildon Picker button should disable itself if there are no
+    values)
+  * Fixes: NB#89650 (Picker button is not updated, when selection in selector
+    has changed)
+
+  API additions:
+
+  * HildonTouchSelectorColumn::text-column property.
+  * hildon_picker_button_set_done_button_text() and
+    hildon_picker_button_get_done_button_text()
+  * HildonCheckButton is a proper widget.
+
+  Deprecations:
+
+  * HildonWeekdayPicker
+  * HildonTouchSelectorEntry::text-column property, use
+    HildonTouchSelectorColumn::text-column instead.
+  * hildon_touch_selector_set_column_attributes(), use
+    HildonTouchSelectorColumn and friends.
+  * HildonAppMenu::columns property, this is managed automatically now.
+
+  Other:
+
+  * hildon_gtk_set_theme_size() sets widget name using "WidgetName-size" layout,
+    to ease proper theming (Daniel Borgmann)
+  * Many documentation improvements and additions.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Fri, 10 Oct 2008 13:40:57 +0300
+
+libhildon (2.1.12-2) unstable; urgency=low
+
+  * Add missing hildon-touch-selector-column.h to installable headers.
+  * Fix dh_makeshlibs rule.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Wed, 01 Oct 2008 13:02:43 +0300
+
+libhildon (2.1.12-1) unstable; urgency=low
+
+  * Ship the upstream ChangeLog and NEWS file.
+
+  Bug fixes:
+
+  * Fixes: NB#88576 (critical warning in HildonTouchSelectorEntry)
+  * Fixes: NB#88720 (HildonPickerButton leaks a reference to the
+    HildonTouchSelector)
+  * Fixes: NB#88718 (HildonPickerButton not synchronizing its initial
+    'value' with the selector)
+  * Fixes: NB#88891 (Allow WM to handle properly close-on-tap-outside behavior)
+  * Fixes: NB#88850 (Update HildonNote button strings + signals)
+  * Fixes: NB#88887 (Hildon Wizard changes for Hildon2.2)
+  * Fixes: NB#88680 (Limiting API in HildonTouchSelector)
+  * Fixes: NB#88923 (Semantics of hildon_stackable_window_set_main_menu()
+    changed)
+  * Fixes: NB#88927 (Hildon Wizard should not use icons anymore)
+
+  API additions:
+
+  * New methods to set/get index of selected item in HildonPickerButton and
+    HildonTouchSelector.
+  * Add HildonAppMenu::columns property.
+  * New HildonTouchSelectorColumn class implementing GtkCellLayout interface.
+
+  Other:
+
+  * Examples updated, coding, theming, and documentation fixes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 29 Sep 2008 10:08:47 +0300
+
+libhildon (2.1.10-2) unstable; urgency=low
+
+  * Revert bump of shared library version to avoid shared library load issues.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Wed, 17 Sep 2008 10:52:21 +0300
+
+libhildon (2.1.10-1) unstable; urgency=low
+
+  * Fixes: NB#88214 (HildonPannableArea wrong requisition)
+  * Fixes: NB#88287 (Missing translations)
+  * Fixes: NB#88364 (Update margins definitions)
+  * Fixes: NB#88414 (Crash in HildonDateSelector on finalize)
+  * New widget: HildonTextEntry.
+  * Removed long deprecated methods hildon_check_button_set_label(),
+    hildon_check_button_get_label().
+  * New method: hildon_gtk_window_set_progress_indicator() to set progress indicator in
+    windows (depends on feature being implemented in WM).
+  * Documentation updates, coding fixes, examples updates. See ChangeLog for details.
+  * Add dependency of libhildon1 on hildon-libs-l10n-mr[0]
+  * Set myself as the maintainer of the debian package.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 15 Sep 2008 15:36:06 +0300
+
+libhildon (2.1.8-1) unstable; urgency=low
+
+  * Make -gdb package contain useful debugging symbols.
+  * Fixes: NB#88022 (parameter validation in
+    hildon_touch_selector_get_num_columns)
+  * Fixes: NB#88023 (day range check
+    in hildon_date_selector_select_current_date)
+  * Fixes: NB#88027 (implement hildon_date_selector_select_month)
+  * Fixes: NB#88045 (fix logical id for time in HildonTimeSelector)
+  * Fixes: NB#88047 (fix retrieval of selected items in HildonTouchSelector)
+  * Fixes: NB#88036 (fix range of 12h time in HildonTimeSelector)
+  * Fixes: NB#88049 (fix columns removal from HildonTouchSelector)
+  * New hildon_button_get_image() method in HildonButton.
+  * New widget: HildonEntry.
+  * New methods to add buttons with finger size in HildonDialog.
+  * Miscellaneous improvements, other minor bug fixes, documentation
+    improvementsand examples updates. See ChangeLog for details.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 09 Sep 2008 10:47:11 +0300
+
+libhildon (2.1.6-1) unstable; urgency=low
+
+  * Deprecated hildon_check_button_{set/get}_label().
+  * Renamed HILDON_PANNABLE_AREA_MOV_* macros to HILDON_MOVEMENT_*
+  * Initial hint in the pannable area set to FALSE.
+  * Renamed properties in HildonPannableArea from {h,v}indicator-mode to
+    {h,v}indicator_policy, and {h,v}scroll to {h,v}scroll_visible.
+  * New widget: HildonEditToolbar.
+  * Renamed hildon_touch_selector_{set,get}_active_iter() to
+    hildon_touch_selector_select_iter() and hildon_touch_selector_get_selected().
+  * Several API additions, bug fixes, internals improvements, documentation
+    improvements, and examples updates. See ChangeLog for details.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Fri, 29 Aug 2008 15:25:33 +0300
+
+libhildon (2.1.5-1~unreleased) gutsy; urgency=low
+
+  * Replace esd dependencies in the dev package with libcanberra-dev.
+    Fixes: NB#87481
+
+ -- Kimmo Hämäläinen <kimmo.hamalainen@nokia.com>  Wed, 13 Aug 2008 16:10:36 +0300
+
+libhildon (2.1.4-1) gutsy; urgency=low
+
+  * Lot of changes, see ChangeLog for more information.
+  * Depending on the new Gtk+.
+
+ -- Kimmo Hämäläinen <kimmo.hamalainen@nokia.com>  Tue, 12 Aug 2008 18:22:00 +0300
+
+libhildon (2.1.3-1) gutsy; urgency=low
+
+  * Tons of changes, see the ChangeLog for more information.
+  * Replaced libesd with libcanberra. Fixes: NB#86876
+
+ -- Kimmo Hämäläinen <kimmo.hamalainen@nokia.com>  Mon,  4 Aug 2008 15:07:03 +0300
+
+libhildon (2.1.2-1) gutsy; urgency=low
+
+  * Update version number to 2.1.2-1
+  * configure.ac 2.1.2
+  * Too many individual changes for them to all be relevant here, many widgets
+    added, many widgets have been changed. A full list of additional/changed  widgets
+    can be found in the Hildon 2.2 widget UI spec.
+
+ -- Karl Lattimer <karl.lattimer@nokia.com>  Mon, 30 Jun 2008 13:55:29 +0300 
+
 libhildon (2.1.1-1) gutsy; urgency=low
 
   * Update version number to 2.1.1-1