2009-03-24 Claudio Saavedra <csaavedra@igalia.com>
[hildon] / debian / changelog
index db0f4cb..4a38c72 100644 (file)
@@ -1,3 +1,578 @@
+libhildon (2.1.56-1) unstable; urgency=low
+
+  * Fixes: NB#107494 (Items stay selected when clicking and moving
+    away when inside pannable area)
+  * Fixes: NB#103564 (Make hildon animation banner use individual image
+    files as the animation)
+  * Fixes: NB#107471 (hildon_entry_set_text() not setting the text
+    when the placeholder text is already set)
+  * Bump GTK+ dependency to 2:2.12.12-1maemo12.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 24 Mar 2009 16:56:29 +0200
+
+libhildon (2.1.54-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#105190 (Text input area of HildonTouchSelectorEntry to
+    be selected manually for the HW keys to work)
+  * Fixes: NB#105427 (Clicking and dragging (for pixel values more
+    than the threshold value) within the button is not sending the
+    event to the child)
+  * Fixes: NB#106607 (hildon_init should issue error message upon successive calls)
+
+  Other:
+
+  * Improved usability in HildonPannableArea and HildonTouchSelectorEntry.
+  * Some examples cleaned up.
+  * Code fixes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 23 Mar 2009 10:09:21 +0200
+
+libhildon (2.1.52-2) unstable; urgency=low
+
+  * Reverted some changes that were causing problems in the date-button creation
+
+ -- Alejandro G. Castro <alex@igalia.com>  Thu, 19 Mar 2009 13:58:33 +0200
+
+libhildon (2.1.52-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#104485 (Not able to address the call when application menu is
+    opened at background)
+  * Fixes: NB#105507 (hildon_date_button_set_date leads to crash.)
+  * Fixes: NB#105407 (highlight is not cancelled when panning starts)
+  * Fixes: NB#105455 (HildonTouchSelectorPrintFunc lacks user data)
+  * Fixes: NB#105678 (HildonTextView should use logical colours instead of
+    setting widget name)
+
+  New API:
+
+  * (HildonTouchSelectorPrintFunc *) (HildonTouchSelector * selector, gpointer user_data)
+  User data parameter added to (HildonTouchSelectorPrintFunc *) signature.
+  * hildon_touch_selector_set_print_func_full (): support for user data and a destroy callback.
+
+  Other:
+
+  * More HildonPannableArea fine tunning.
+  * Documentation improvements.
+  * Minor theming fixes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 16 Mar 2009 10:50:54 +0200
+
+libhildon (2.1.50-1) unstable; urgency=low
+
+  * Fixes: NB#105012 (buttons inside a pannable area not getting release
+    event when dragging/releasing)
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 10 Mar 2009 16:40:03 +0200
+
+libhildon (2.1.48-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#103758 (No way to obtain a menu from a  HildonStackableWindow)
+  * Fixes: NB#103761 (HildonAppMenu doesn't have methods to get its children)
+  * Fixes: NB#104439 (hildon_date_button_new() isn't set to the current date by
+    default)
+  * Fixes: NB#104485 (Not able to address the call when application menu is
+  opened at background)
+  * Fixes: NB#104819 (Clean up old icon names from hildon-widgets)
+  * Fixes: NB#104815 (I need accessor to the entry inside
+  HildonTouchSelectorEntry)
+  * Fixes: NB#102541 (value entered in the touch selector entry is not shown
+  when opened for second time)
+
+  New API:
+
+  * HildonAppMenu:
+    hildon_app_menu_get_items()
+    hildon_app_menu_get_filters()
+    HildonAppMenu::filter-vertical-spacing style property.
+  * hildon_stackable_window_{get,set}_app_menu()
+  * hildon_window_get_main_menu()
+  * hildon_touch_selector_entry_get_entry()
+  * HildonPannableArea properties:
+    ::drag-inertia, ::panning-threshold, ::scrollbar-fade-delay,
+    ::bounce-steps, ::force and ::direction-error-margin
+
+  Deprecations:
+
+  * hildon_window_get_menu(): use hildon_window_get_main_menu()
+  * hildon_stackable_window_set_main_menu(): use hildon_stackable_window_set_app_menu()
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 09 Mar 2009 10:15:08 +0200
+
+libhildon (2.1.46-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#101603 (Focus is not even for the text entry boxes in
+    Contact editor dialog)
+  * Fixes: NB#92297 (Preview content is not clearly visible for
+    default colour text)
+  * Fixes: NB#101889 (Picker dialog should not close when nothing is
+    selected in multiple selection list)
+  * Fixes: NB#97458 (Pannable area prevents propagation of button
+    press events)
+  * Fixes: NB#103242 ("HildonPickerButton:value-changed" is emitted
+    before actual change of values)
+  * Fixes: NB#100468 (Application menu window is launched even when a
+    new secondary-window/dialog is pending to be shown/realized)
+
+  New API:
+
+  * hildon_app_menu_popup(): New function to pop up a HildonAppMenu
+  * hildon_picker_button_value_changed(): Programmatically emit "value-changed".
+
+  Other:
+
+  * unit testing suite fixes (Sven Herzberg)
+  * Removed hildon-remote-texture.h from hildon.h.
+  * Themability improvements.
+  * Code fixes.
+  * HildonPannableArea improvements.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 02 Mar 2009 11:38:42 +0200
+
+libhildon (2.1.44-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#100646 (Logical strings is shown for ok in set
+    password,Password needed dialogs)
+  * Fixes: NB#100445 (Hildon banner gets destroyed when a dialog is
+    opened)
+  * Fixes: NB#101916 (Do not allow custom icons on animation banner)
+  * Fixes: NB#101698 (Back button long press and delete-event handling)
+  * Fixes: NB#99915 (Date and Time options are not localised in Date
+    and Time setttings)
+  * Fixes: NB#101043 (Second row of all the command button are
+    displayed in transparent mode.)
+  * Fixes: NB#102225 (Crash setting the progress indicator to a non
+    visible window)
+  * Fixes: NB#102262 (memory leak in hildon_button_set_style())
+  * Fixes: NB#101793 (Make edit toolbar the same height as window
+    title bar (use title area theming))
+  * Fixes: NB#102467 (Do not show highlight on the text in
+    HildonCaption)
+  * Fixes: NB#102338 (HildonPannableArea scrolling indicator does not
+    treat ->lower correctly)
+  * Fixes: NB#102413 (The text margins (wrapping) in information
+    banner should be HILDON_MARGIN_TRIPLE)
+
+  New API:
+
+  * HildonRemoteTexture (Gordon Williams)
+  * HildonPannableArea:low-friction-mode property.
+
+  Deprecations:
+
+  * hildon_banner_show_annimation(): No more user defined icons.
+
+  Other:
+
+  * Theming improvements.
+  * Increased the maximum speed of the pannable area to improve usability.
+  * Memory leaks fixed and other code fixes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Fri, 20 Feb 2009 15:12:02 +0200
+
+libhildon (2.1.42-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#100487 (HildonStackableWindow transiency becomes
+    incoherent)
+  * Fixes: NB#98039 (Wishlist: hildon_window_add_edit_toolbar())
+  * Fixes: NB#100320 (HildonPannableArea does not listen to
+    GtkAdjustment "change" signals)
+  * Fixes: NB#99802 (Hildon touch selector entry not working properly
+    for some of the input modes)
+  * Fixes: NB#100468 (Application menu window is launched even when a
+    new secondary-window/dialog is pending to be shown/realized.)
+  * Fixes: NB#93165 (HildonTouchSelector::changed not emitted when the
+    selection is programmatically changed)
+
+  Deprecations:
+
+  * Removed obsolete icon sizes:
+    HILDON_ICON_PIXEL_SIZE_WIZARD
+    HILDON_ICON_PIXEL_SIZE_BIG_NOTE
+    HILDON_ICON_PIXEL_SIZE_NOTE
+
+  Other:
+
+  * Documentation improvements.
+  * Misc. code improvements.
+  * Icon sizes updates.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Fri, 06 Feb 2009 09:51:54 +0200
+
+libhildon (2.1.40-1) unstable; urgency=low
+
+  * bump GTK+ dependency to 2.12.12-1maemo7
+
+  Bug fixes:
+
+  * Fixes: NB#98855 (HildonBanner uses qgn_note_infoprint)
+  * Fixes: NB#98614 (Hildon information note (background) should have
+    minimum height and maximum text width)
+  * Fixes: NB#91657 (HildonPickerDialog closes immediately when used
+    with some dynamic tree model)
+  * Fixes: NB#97468 (HildonPickerDialog doesn't need to show selected
+    contents in title)
+  * Fixes: NB#99713 (HildonButton value label color is wrong)
+  * Fixes: NB#94970 (Hildon Edit Mode Toolbar should use back button
+    graphics from theme)
+
+  Other:
+
+  * Do not use cairo to render the HildonPannableArea panning indicators.
+  * HildonButton layout fixes.
+  * Improved and updated examples.
+  * Documentation improvements.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 02 Feb 2009 09:25:09 +0200
+
+libhildon (2.1.38-1) unstable; urgency=low
+
+  * fix DEB_BUILD_OPTIONS=nodocs
+
+  Bug fixes:
+
+  * Fixes: NB#98609 (Use wdgt_ strings for all hildon dialog buttons)
+  * Fixes: NB#98537 (Device hangs in account settings dialog)
+  * Fixes: NB#95395 (prestarted applications show GLIB WARNING ** Gdk
+    - gdkdrawable-x11.c:878 drawable is not a pixmap or window)
+  * Fixes: NB#98383 (is-topmost signal is not emitted when task
+    switcher is clicked.)
+
+  New API:
+
+  * New HildonAnimationActor widget (Artem Egorkine)
+
+  Other:
+
+  * Reverted change in pannable area that caused irresponsive applications.
+  * Pannable Area misc. improvements.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 26 Jan 2009 10:59:00 +0200
+
+libhildon (2.1.36-2) unstable; urgency=low
+
+  * Fix a potencial lock HildonPickerButton.
+  * Fix a potencial crasher in HildonTimeSelector.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Thu, 22 Jan 2009 19:14:33 +0200
+
+libhildon (2.1.36-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#93410 (API required for setting IM mode in HildonTouchSelectorEntry)
+  * Fixes: NB#97015 (HildonPickerButton shouldn't gtk_dialog_run() the picker dialog)
+  * Fixes: NB#95828 (HildonTextView functionality)
+  * Fixes: NB#96202 (FKB causes HildonPickerButton's value update before the selection is accepted in the dialog)
+  * Fixes: NB#94970 (Hildon Edit Mode Toolbar should use back button graphics from theme)
+  * Fixes: NB#96225 (Dialog titles are not shown according to the values selected in the list picker)
+  * Fixes: NB#96226 (In multiple selection mode Done button is shown sometimes in listpicker)
+  * Fixes: NB#96837 (HildonPannableArea - scroll indicator shown despite the view not being scrollable)
+  * Fixes: NB#95709 (Invalid casts in HildonPannableArea(?))
+  * Fixes: NB#97028 (Pannable area updates on every motion event)
+  * Fixes: NB#92849 (Selected item is not always visible when HildonTouchSelector is shown)
+  * Fixes: NB#97908 (Not possible to change the year range in HildonDateSelector/HildonDateButton)
+  * Fixes: NB#98317 (Provide parametarized API for TimePicker widget)
+
+  New API:
+
+  * HildonPickerDialog:
+
+    - ::center-on-show property:
+      Whether to center on the selected items each time the dialog is presented.
+
+  * HildonTouchSelector:
+
+    - hildon_touch_selector_entry_set/get_input_mode: New accessors for
+      the input mode used in a HildonTouchSelectorEntry's entry.
+    - hildon_touch_selector_unselect_all(): Unselect current selection
+      in one of the columns.
+    - hildon_touch_selector_center_on_selected(): Centers on the nearest
+      selected element in each column.
+
+  * HildonDateSelector:
+
+    - ::min-year, ::max-year properties:
+      Allows to define boundaries for the year column in the selector.
+    - hildon_date_selector_new_with_year_range():
+      Create a date selector with custom year boundaries.
+
+  * HildonDateButton:
+
+    - hildon_date_button_new_with_year_range():
+      Create a button with custom year boundaries in its date selector.
+
+  * HildonEditToolbar:
+
+    - ::arrow-width and ::arrow-height style properties:
+      Allow to set the size of the arrow button.
+
+  * HildonTimeSelector:
+
+    - ::minutes-step:
+      Allows to define steps between minutes in the time selector.
+    - hildon_time_selector_new_step():
+      Allows to create a HildonTimeSelector with a custom minutes step.
+
+  * HildonTimeButton:
+
+    - hildon_time_button_new_step():
+      Allows to create a HildonTimeButton with a custom minutes step in
+      its selector.
+
+  Other:
+
+  * Improved documentation.
+  * Many code fixes and memory leaks fixed.
+  * Improved HildonPannableArea responsiveness/performance.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 20 Jan 2009 14:29:55 +0200
+
+libhildon (2.1.34-2) unstable; urgency=low
+
+  * Fixes: NB#94460 (stackable window's menu is not closed when its
+  window is hidden)
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Thu, 08 Jan 2009 11:35:40 +0200
+
+libhildon (2.1.34-1) unstable; urgency=low
+
+  [ Alberto Garcia ]
+  * Use dh_install to install all examples.
+  * Use DEB_SRCDIR instead of defining SOURCE_DIR
+
+  Bug fixes:
+
+  * Fixes: NB#94460 (stackable window's menu is not closed when its
+  window is hidden)
+  * Fixes: NB#89890 (Information notes does not get disappeared after
+  few seconds)
+
+  Other:
+
+  * Code cleanups, minor fixes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 16 Dec 2008 13:25:38 +0100
+
+libhildon (2.1.32-1) unstable; urgency=low
+
+  * Bump GTK+ dependency to 2.12.12-1maemo5.
+
+  Bug fixes:
+
+  * Fixes: NB#95714 (GtkCellView in HildonCheckButton should be
+    larger / configurable size)
+
+  Other:
+
+  * Quick release to update a GtkRange property change in GTK+.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 16 Dec 2008 13:10:47 +0100
+
+libhildon (2.1.30-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#93744 (Tapping should jump to location on GtkScale)
+
+  New API:
+
+  * hildon_pannable_area_get_[sv]adjustment(): Method to retrieve the GtkAdjustments
+    in HildonPannableArea.
+
+  Other:
+
+  * Code fixes.
+  * Leaks fixed.
+  * New progress indicator example (Thomas Thurman)
+  * Documentation improvements and updates (Ivan Gomez).
+  * Theme properly HildonPickerButton derived classes.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 15 Dec 2008 11:55:23 +0100
+
+libhildon (2.1.28-1) unstable; urgency=low
+
+  * Bump GTK+ dependency to 2.12.12-1maemo4 for the GtkDialog changes.
+
+  Bug fixes:
+
+  * Fixes: NB#94214 (No way to stop HildonWizardDialog from going to
+    next page)
+  * Fixes: NB#94972 (Hildon Picker with Entry should use HildonEntry
+    widget, not GtkEntry)
+  * Fixes: NB#90867 (Deprecate HildonDialog and use GtkDialog (with
+    maemo changes) instead)
+
+  New API:
+
+  * hildon_program_set/get_common_app_menu(): Use to set a common
+    HildonAppMenu for all stackable windows in a HildonProgram.
+  * hildon_wizard_dialog_set_forward_page_func(): Use to define a
+    HildonWizardDialogPageFunc function to control flow of the wizard.
+  * hildon_gtk_tree_view_set_ui_mode(): Method to change the UI mode.
+  * hildon_gtk_icon_view_set_ui_mode(): Method to change the UI mode.
+  * HildonPannableArea::size-request-policy: Size requisition policy property.
+  * hildon_pannable_area_set/get_size_request_policy(): Method to change the
+    size request policy.
+
+  Deprecations:
+
+  * HildonDialog. Prefer GtkDialog instead.
+
+  Other:
+
+  * Examples updated, code fixes, documentation updates.
+  * Explicitely set the interactive search widget off in hildon specific
+    GtkTreeView.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 09 Dec 2008 16:09:45 +0100
+
+libhildon (2.1.26-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#92230 (Scroll indication not visible in HildonTouchSelector)
+  * Fixes: NB#93281 (new API: hildon_button_set_picker_style() to set
+    HildonButton look like PickerButton)
+  * Fixes: NB#93680 (HildonTimePicker need fully localized am/pm)
+  * Fixes: NB#93228 (Done button is not shown always in listpicker)
+  * Fixes: NB#93890 (Empty HildonAppMenu is pop-up)
+  * Fixes: NB#92032 (In calendar application, date values in 'new event'
+    are not proper)
+  * Fixes: NB#94322 (Scale Updates)
+  * Fixes: NB#94350 (HildonWindowStack:s have the same X Window group)
+
+  New API:
+
+  * HildonWindowStack: Support for multiple window stacks per application.
+  * HildonButton::style property. See below.
+  * hildon_button_set_picker_style(): Sets a different style to the value label
+    in HildonButton.
+  * HildonTouchSelector:columns-changed signal: Emitted every time the number
+    of columns in a HildonTouchSelector changes.
+
+  Deprecations:
+
+  * hildon_program_pop_window_stack(),
+    hildon_program_peek_window_stack(),
+    hildon_program_go_to_root_window(): Superseded by HildonWindowStack.
+
+  Other:
+
+  * Many code fixes.
+  * Examples updates and improvements.
+  * Documentation improvements.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Wed, 03 Dec 2008 09:17:52 +0100
+
+libhildon (2.1.24-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#89811 (Not able to select first image thumbnail in multi
+    selection mode using custom widget inside pannable)
+  * Fixes: NB#91863 (hildon_touch_selector_set_column_selection_mode()
+    breaks HildonPickerDialog)
+  * Fixes: NB#91769 (HildonColorChooserDialog's selected colour is
+    highlighted but not visible)
+  * Fixes: NB#92897 (HildonNotes have incorrect WINDOW_TYPE)
+  * Fixes: NB#92744 (HildonDateSelector emits multiple "changed" singal
+    with strange parameters)
+  * Fixes: NB#92664 (Deprecate hildon_helper_set_insensitive_message)
+  * Fixes: NB#89754 (Applications shouldn't display their names in the
+    window title)
+  * Fixes: NB#92476 (Update icon size constants to Fremantle (hildon-defines.h))
+
+  Deprecations:
+
+  * hildon_helper_set_insensitive_message()
+  * hildon_helper_set_insensitive_messagef()
+  * hildon_volumebar_set_range_insensitive_message()
+  * hildon_volumebar_set_range_insensitive_messagef()
+
+  New API:
+
+  * hildon_init(): Initialization function for the library.
+  * hildon_gtk_init(): Convenience init function for hildon and GTK+
+
+  Other:
+
+  * Build system improvements.
+  * Examples updated.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Mon, 24 Nov 2008 15:21:49 -0300
+
+libhildon (2.1.22-1) unstable; urgency=low
+
+  [ Alejandro Pinheiro ]
+  * Added --enable-maintainer-mode on debian/rules
+
+  Bug fixes:
+
+  * Fixes: NB#91688 (Never show icons in information notes/confirmation
+    notes)
+  * Fixes: NB#91995 (Calendar is crashing after pressing 'Enter' HW key
+    in HildonDateSelector dialog)
+
+  Deprecations:
+
+  * hildon_note_new_confirmation_with_icon_name(): deprecated
+  * hildon_note_new_information_with_icon_name(): deprecated
+  * HildonNote::icon and HildonNote::stock_icon: deprecated
+
+  Other:
+
+  * Logical ids fixes.
+  * Examples updated.
+  * Build system improved.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 11 Nov 2008 07:05:33 -0300
+
+libhildon (2.1.20-1) unstable; urgency=low
+
+  Bug fixes:
+
+  * Fixes: NB#89541 (Crash in pannable area when closing picker dialog)
+  * Fixes: NB#90994 (HildonPannableArea does not connect "destroyed"
+    on child)
+  * Fixes: NB#91192 (Memory leak in HildonTouchSelector default print
+    function)
+  * Fixes: NB#91135 (Deprecate legacy hildon widgets)
+  * Fixes: NB#90662 (HildonButton "value" and "detail" text is
+    unformatted)
+  * Fixes: NB#91104 (Remove stepper buttons from legacy hildon widgets)
+  * Fixes: NB#91016 (Change toolbar sizes, simplification)
+  * Fixes: NB#91385 (Hildon Touch List panning should be ALWAYS vertical only)
+
+  Deprecations:
+
+  * All Fremantle deprecated widgets has been marked as such with
+    HILDON_DISABLE_DEPRECATED marks.
+
+  Other:
+
+  * Improved sizing of the HildonTouchSelector/HildonPickerDialog widgets.
+  * Corrected alignment of HildonCheckButton contents.
+  * Many cancel-like button fixes.
+
+  ABI:
+
+  * Reverted change introduced in 2.1.16 that broke ABI compatibility. See
+    NB#91636 for further explanation.
+
+ -- Claudio Saavedra <csaavedra@igalia.com>  Tue, 04 Nov 2008 13:40:40 +0200
+
 libhildon (2.1.18-1) unstable; urgency=low
 
   [ Alejandro Pinheiro ]