implemented draft of config globalization
[findit] / debian / rules
index 6e435f5..09e56ff 100755 (executable)
@@ -3,25 +3,27 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+PACKAGE=findit
+PYTHON=PYTHONOPTIMIZE=2 python
 
-build-stamp: configure-stamp
+build:
        dh_testdir
 
        # Add here commands to compile the package.
-       mkdir -p $(CURDIR)/ru/LC_MESSAGES
-       msgfmt ru.po -o $(CURDIR)/ru/LC_MESSAGES/findit.mo
-       python setup.py build
+       mkdir -p $(CURDIR)/po/ru/
+       msgfmt $(CURDIR)/po/ru.po -o $(CURDIR)/po/ru/$(PACKAGE).mo
+       $(PYTHON) setup.py build
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       rm -rf $(CURDIR)/ru
+       rm -rf $(CURDIR)/po/ru
 
        # Add here commands to clean up after the build process.
-       python setup.py clean --all
+       $(PYTHON) setup.py clean --all
+
+       rm -rf $(CURDIR)/$(PACKAGE).egg-info/
 
        dh_clean 
 
@@ -29,25 +31,17 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
-       dh_installdirs
 
        # Add here commands to install the package into debian/findit
-       python setup.py install --root $(CURDIR)/debian/findit
+       $(PYTHON) setup.py install --root $(CURDIR)/debian/$(PACKAGE)
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
-       dh_installexamples
-       dh_installman
        dh_link
-       dh_strip
        dh_compress
        dh_fixperms
        dh_installdeb
@@ -55,5 +49,9 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+
+.PHONY: build clean binary-indep binary-arch binary install