implemented draft of config globalization
[findit] / debian / rules
index aedf80a..09e56ff 100755 (executable)
@@ -3,25 +3,27 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+PACKAGE=findit
+PYTHON=PYTHONOPTIMIZE=2 python
 
-build-stamp: configure-stamp
+build:
        dh_testdir
 
        # Add here commands to compile the package.
-       mkdir -p $(CURDIR)/ru/LC_MESSAGES
-       msgfmt ru.po -o $(CURDIR)/ru/LC_MESSAGES/findit.mo
-       python setup.py build
+       mkdir -p $(CURDIR)/po/ru/
+       msgfmt $(CURDIR)/po/ru.po -o $(CURDIR)/po/ru/$(PACKAGE).mo
+       $(PYTHON) setup.py build
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       rm -rf $(CURDIR)/ru
+       rm -rf $(CURDIR)/po/ru
 
        # Add here commands to clean up after the build process.
-       python setup.py clean --all
+       $(PYTHON) setup.py clean --all
+
+       rm -rf $(CURDIR)/$(PACKAGE).egg-info/
 
        dh_clean 
 
@@ -31,7 +33,7 @@ install: build
        dh_clean -k 
 
        # Add here commands to install the package into debian/findit
-       python setup.py install --root $(CURDIR)/debian/findit
+       $(PYTHON) setup.py install --root $(CURDIR)/debian/$(PACKAGE)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -51,4 +53,5 @@ binary-indep: build install
 binary-arch: build install
 
 binary: binary-indep binary-arch
+
 .PHONY: build clean binary-indep binary-arch binary install