implemented draft of config globalization
[findit] / debian / rules
index fa35cde..09e56ff 100755 (executable)
@@ -4,6 +4,7 @@
 #export DH_VERBOSE=1
 
 PACKAGE=findit
+PYTHON=PYTHONOPTIMIZE=2 python
 
 build:
        dh_testdir
@@ -11,7 +12,7 @@ build:
        # Add here commands to compile the package.
        mkdir -p $(CURDIR)/po/ru/
        msgfmt $(CURDIR)/po/ru.po -o $(CURDIR)/po/ru/$(PACKAGE).mo
-       python setup.py build
+       $(PYTHON) setup.py build
        touch $@
 
 clean:
@@ -20,7 +21,9 @@ clean:
        rm -rf $(CURDIR)/po/ru
 
        # Add here commands to clean up after the build process.
-       python setup.py clean --all
+       $(PYTHON) setup.py clean --all
+
+       rm -rf $(CURDIR)/$(PACKAGE).egg-info/
 
        dh_clean 
 
@@ -30,7 +33,7 @@ install: build
        dh_clean -k 
 
        # Add here commands to install the package into debian/findit
-       python setup.py install --root $(CURDIR)/debian/$(PACKAGE)
+       $(PYTHON) setup.py install --root $(CURDIR)/debian/$(PACKAGE)
 
 # Build architecture-independent files here.
 binary-indep: build install