Merge branch 'master' into cache
[mdictionary] / debian / rules
index 3fc742e..71bcc21 100755 (executable)
@@ -1,77 +1,56 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 # Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+APPNAME := mdictionary
 
+builddir:
+       mkdir -p builddir
 
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-       INSTALL_PROGRAM += -s
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
+builddir/Makefile: builddir
+       cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 
 
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp: builddir/Makefile
        dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE)
-       #/usr/bin/docbook-to-man debian/whitestork.sgml > whitestork.1
-
-       touch build-stamp
+       cd builddir && $(MAKE)
+       touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
-       dh_clean 
+       rm -f build-stamp
+       rm -rf builddir
+       dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
        dh_installdirs
-
-       # Add here commands to install the package into debian/whitestork.
-       $(MAKE) install-manager DESTDIR=$(CURDIR)/debian/whitestork
-       $(MAKE) install-gui DESTDIR=$(CURDIR)/debian/whitestorkgui
-       $(MAKE) install-plugins DESTDIR=$(CURDIR)/debian/whitestorkplugins
-
-
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
+       ./rename-plugins "$(CURDIR)/debian/$(APPNAME)/usr/lib/mdictionary"
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
 
 # Build architecture-dependent files here.
 binary-arch: build install
+       
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
-#      dh_installexamples
+       dh_installexamples
 #      dh_install
 #      dh_installmenu
 #      dh_installdebconf       
@@ -82,8 +61,8 @@ binary-arch: build install
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
-#      dh_installman
-#      dh_link
+       dh_installman
+       dh_link
        dh_strip
        dh_compress
        dh_fixperms