* unbreak configure.ac
[modest] / debian / rules
index 8e88ca5..ce62387 100755 (executable)
@@ -13,7 +13,7 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 
-CFLAGS = -Wall -g
+CFLAGS = -Wall -Wno-format -g
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -23,11 +23,15 @@ endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
+ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -mthumb
+endif
 
-config.status: configure
+config.status:
+       if [ ! -x configure ]; then ./autogen.sh; fi
        dh_testdir
        # Add here commands to configure the package.
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
 
 
 build: build-stamp
@@ -37,7 +41,6 @@ build-stamp:  config.status
 
        # Add here commands to compile the package.
        $(MAKE)
-       #/usr/bin/docbook-to-man debian/modest.sgml > modest.1
 
        touch build-stamp
 
@@ -64,7 +67,7 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/modest.
+       # Add here commands to install the package into debian/modest
        $(MAKE) install DESTDIR=$(CURDIR)/debian/modest
 
 
@@ -76,7 +79,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
+#      dh_installchangelogs ChangeLog
 #      dh_installdocs
 #      dh_installexamples
 #      dh_install
@@ -96,7 +99,7 @@ binary-arch: build install
        dh_fixperms
 #      dh_perl
 #      dh_python
-       dh_makeshlibs
+#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol