unified way of changes for debian/rules
[maemo-efl] / trunk / eet / debian / rules
index 5704715..7692742 100755 (executable)
@@ -4,8 +4,9 @@
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 
-#DEB_MAKE_CLEAN_TARGET := clean
+DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
+        CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+endif
 
-#clean::
-#      if [ -f $(CURDIR)/../../snapshot ]; then ./autogen.sh --prefix=/usr; fi
-