Update debian/changelog
[browser-switch] / debian / rules
index c773a37..014ed5e 100755 (executable)
@@ -9,8 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
+# Optimize for N8x0 CPUs if building for armel
+ifeq ($(DEB_HOST_ARCH),armel)
+       EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries if requested
+       ifneq (,$(filter thumb,$(DEB_BUILD_OPTIONS)))
+               EXTRA_CFLAGS += -mthumb
+       endif
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -22,8 +28,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make
-       make -C config-ui
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
 
        touch $@
 
@@ -46,7 +52,7 @@ install: build
        # Add here commands to install the package into
        # debian/browser-switchboard.
        make DESTDIR=debian/browser-switchboard install
-       make -C config-ui DESTDIR=debian/browser-switchboard install
+       make -C config-ui DESTDIR=../debian/browser-switchboard install
 
 
 binary-indep: build install