Drop the Depends on tablet-browser-ui for Diablo, for now
[browser-switch] / debian / rules
index e3dcdc4..014ed5e 100755 (executable)
@@ -9,8 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
+# Optimize for N8x0 CPUs if building for armel
+ifeq ($(DEB_HOST_ARCH),armel)
+       EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries if requested
+       ifneq (,$(filter thumb,$(DEB_BUILD_OPTIONS)))
+               EXTRA_CFLAGS += -mthumb
+       endif
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -22,8 +28,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make
-       make -C config-ui
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
 
        touch $@
 
@@ -32,6 +38,9 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
+       make clean
+       make -C config-ui clean
+
        dh_clean 
 
 install: build
@@ -43,7 +52,7 @@ install: build
        # Add here commands to install the package into
        # debian/browser-switchboard.
        make DESTDIR=debian/browser-switchboard install
-       make -C config-ui DESTDIR=debian/browser-switchboard install
+       make -C config-ui DESTDIR=../debian/browser-switchboard install
 
 
 binary-indep: build install