Build Fremantle-specific code by passing -DFREMANTLE in EXTRA_CPPFLAGS
[browser-switch] / debian / rules
index 014ed5e..04f7738 100755 (executable)
@@ -9,15 +9,16 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# Optimize for N8x0 CPUs if building for armel
 ifeq ($(DEB_HOST_ARCH),armel)
-       EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       #EXTRA_CFLAGS += -mcpu=arm1136jf-s
        # Use Thumb for smaller binaries if requested
        ifneq (,$(filter thumb,$(DEB_BUILD_OPTIONS)))
                EXTRA_CFLAGS += -mthumb
        endif
 endif
 
+EXTRA_CPPFLAGS = -DFREMANTLE
+
 configure: configure-stamp
 configure-stamp:
        touch configure-stamp
@@ -28,8 +29,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
-       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" EXTRA_CPPFLAGS="$(EXTRA_CPPFLAGS)"
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" EXTRA_CPPFLAGS="$(EXTRA_CPPFLAGS)"
 
        touch $@
 
@@ -53,6 +54,7 @@ install: build
        # debian/browser-switchboard.
        make DESTDIR=debian/browser-switchboard install
        make -C config-ui DESTDIR=../debian/browser-switchboard install
+       install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
 
 
 binary-indep: build install