Update debian/changelog, bump version number
[browser-switch] / debian / rules
index 82a69bf..1ccb8ed 100755 (executable)
@@ -9,8 +9,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
+ifeq ($(DEB_HOST_ARCH),armel)
+       #EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries unless otherwise requested
+       ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
+               EXTRA_CFLAGS += -mthumb
+       endif
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -22,6 +27,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin
+
        touch $@
 
 clean:
@@ -29,6 +37,9 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
+       make clean
+       make -C config-ui clean
+
        dh_clean 
 
 install: build
@@ -37,13 +48,18 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/browser-proxy.
-       install -c -m 0755 browser-proxy debian/browser-proxy/usr/bin/browser-proxy
-       install -c -m 0644 com.nokia.osso_browser.service debian/browser-proxy/usr/share/dbus-1/services
-       install -c -m 0755 browser debian/browser-proxy/usr/bin/browser
+       # Add here commands to install the package into
+       # debian/browser-switchboard.
+       make DESTDIR=debian/browser-switchboard install
+       make -C config-ui DESTDIR=../debian/browser-switchboard install
+       install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
+       install -c -m 0644 debian/microb.desktop debian/browser-switchboard/usr/share/applications/hildon
 
 
 binary-indep: build install
+# arch: any package, nothing to do here
+
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -62,19 +78,16 @@ binary-indep: build install
 #      dh_installinfo
 #      dh_installman
 #      dh_link
-#      dh_strip
+       dh_strip
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary-arch: build install
-# arch: all package, nothing to do here
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure