Add a postinst to kill off prestarted MicroB browser process
[browser-switch] / debian / rules
index e58f626..1ccb8ed 100755 (executable)
@@ -17,9 +17,6 @@ ifeq ($(DEB_HOST_ARCH),armel)
        endif
 endif
 
-EXTRA_CPPFLAGS = -DFREMANTLE `pkg-config --cflags dbus-1`
-EXTRA_LDFLAGS = `pkg-config --libs dbus-1`
-
 configure: configure-stamp
 configure-stamp:
        touch configure-stamp
@@ -30,8 +27,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" diablo
-       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" diablo-plugin
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin
 
        touch $@
 
@@ -56,6 +53,7 @@ install: build
        make DESTDIR=debian/browser-switchboard install
        make -C config-ui DESTDIR=../debian/browser-switchboard install
        install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
+       install -c -m 0644 debian/microb.desktop debian/browser-switchboard/usr/share/applications/hildon
 
 
 binary-indep: build install