Don't build with -mthumb on Fremantle
[browser-switch] / debian / rules
index 201148e..358cfd6 100755 (executable)
@@ -9,14 +9,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# Optimize for N8x0 CPUs if building for armel
-ifeq ($(DEB_HOST_ARCH),armel)
-       EXTRA_CFLAGS += -mcpu=arm1136jf-s
-       # Use Thumb for smaller binaries if requested
-       ifneq (,$(filter thumb,$(DEB_BUILD_OPTIONS)))
-               EXTRA_CFLAGS += -mthumb
-       endif
-endif
+#ifeq ($(DEB_HOST_ARCH),armel)
+       #EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries unless otherwise requested
+       #ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
+       #       EXTRA_CFLAGS += -mthumb
+       #endif
+#endif
 
 configure: configure-stamp
 configure-stamp:
@@ -28,8 +27,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
-       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)"
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin
 
        touch $@
 
@@ -54,6 +53,7 @@ install: build
        make DESTDIR=debian/browser-switchboard install
        make -C config-ui DESTDIR=../debian/browser-switchboard install
        install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
+       install -c -m 0644 debian/microb.desktop debian/browser-switchboard/usr/share/applications/hildon
 
 
 binary-indep: build install