Update debian/changelog, bump version number
[browser-switch] / debian / rules
index 1ccb8ed..580398e 100755 (executable)
@@ -9,13 +9,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-ifeq ($(DEB_HOST_ARCH),armel)
+#ifeq ($(DEB_HOST_ARCH),armel)
        #EXTRA_CFLAGS += -mcpu=arm1136jf-s
        # Use Thumb for smaller binaries unless otherwise requested
-       ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
-               EXTRA_CFLAGS += -mthumb
-       endif
-endif
+       #ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
+       #       EXTRA_CFLAGS += -mthumb
+       #endif
+#endif
 
 configure: configure-stamp
 configure-stamp:
@@ -28,7 +28,7 @@ build-stamp: configure-stamp
        dh_testdir
 
        make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle
-       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin fremantle-util
 
        touch $@
 
@@ -50,7 +50,7 @@ install: build
 
        # Add here commands to install the package into
        # debian/browser-switchboard.
-       make DESTDIR=debian/browser-switchboard install
+       make DESTDIR=debian/browser-switchboard install install-xsession-script
        make -C config-ui DESTDIR=../debian/browser-switchboard install
        install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
        install -c -m 0644 debian/microb.desktop debian/browser-switchboard/usr/share/applications/hildon