Update debian/rules
[browser-switch] / debian / rules
index 962a2e3..580398e 100755 (executable)
@@ -9,8 +9,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
+#ifeq ($(DEB_HOST_ARCH),armel)
+       #EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries unless otherwise requested
+       #ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
+       #       EXTRA_CFLAGS += -mthumb
+       #endif
+#endif
 
 configure: configure-stamp
 configure-stamp:
@@ -22,8 +27,8 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       make
-       make -C config-ui
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" fremantle-plugin fremantle-util
 
        touch $@
 
@@ -45,8 +50,10 @@ install: build
 
        # Add here commands to install the package into
        # debian/browser-switchboard.
-       make DESTDIR=debian/browser-switchboard install
+       make DESTDIR=debian/browser-switchboard install install-xsession-script
        make -C config-ui DESTDIR=../debian/browser-switchboard install
+       install -c -m 0644 debian/browser-switchboard-cp.desktop debian/browser-switchboard/usr/share/applications/hildon-control-panel
+       install -c -m 0644 debian/microb.desktop debian/browser-switchboard/usr/share/applications/hildon
 
 
 binary-indep: build install