Update debian/rules to build command-line config utility
[browser-switch] / debian / rules
index f6d060c..60f0ec8 100755 (executable)
@@ -9,8 +9,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
-
+# Optimize for N8x0 CPUs if building for armel
+ifeq ($(DEB_HOST_ARCH),armel)
+       EXTRA_CFLAGS += -mcpu=arm1136jf-s
+       # Use Thumb for smaller binaries unless otherwise requested
+       ifeq (,$(filter nothumb,$(DEB_BUILD_OPTIONS)))
+               EXTRA_CFLAGS += -mthumb
+       endif
+endif
 
 configure: configure-stamp
 configure-stamp:
 
 configure: configure-stamp
 configure-stamp:
@@ -22,6 +28,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
 build-stamp: configure-stamp 
        dh_testdir
 
+       make EXTRA_CFLAGS="$(EXTRA_CFLAGS)" diablo
+       make -C config-ui EXTRA_CFLAGS="$(EXTRA_CFLAGS)" diablo-plugin util
+
        touch $@
 
 clean:
        touch $@
 
 clean:
@@ -29,6 +38,9 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
        dh_testroot
        rm -f build-stamp configure-stamp
 
+       make clean
+       make -C config-ui clean
+
        dh_clean 
 
 install: build
        dh_clean 
 
 install: build
@@ -39,12 +51,14 @@ install: build
 
        # Add here commands to install the package into
        # debian/browser-switchboard.
 
        # Add here commands to install the package into
        # debian/browser-switchboard.
-       install -c -m 0755 browser-switchboard debian/browser-switchboard/usr/bin/browser-switchboard
-       install -c -m 0644 com.nokia.osso_browser.service debian/browser-switchboard/usr/share/dbus-1/services
-       install -c -m 0755 browser debian/browser-switchboard/usr/bin/browser
+       make DESTDIR=debian/browser-switchboard install
+       make -C config-ui DESTDIR=../debian/browser-switchboard install
 
 
 binary-indep: build install
 
 
 binary-indep: build install
+# arch: any package, nothing to do here
+
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -63,19 +77,16 @@ binary-indep: build install
 #      dh_installinfo
 #      dh_installman
 #      dh_link
 #      dh_installinfo
 #      dh_installman
 #      dh_link
-#      dh_strip
+       dh_strip
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary-arch: build install
-# arch: all package, nothing to do here
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure